Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

#3646 closed defect (bug) (no action required)

Mailpress conflict - TypeError with slideDown() and ScrollTo()

Reported by: antoviaque Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Groups Keywords:
Cc:

Description

When Mailpress 5.1.1 plugin is activated, clicking on "Comment" or "Replay" links in activity stream of a group results in the following JS exception:

jQuery.extend.swing() at global.js:1265f.fx.step() at jquery.js:18h() at jquery.js:18f.fx.custom() at jquery.js:18f.fx.show() at jquery.js:18f.fn.extend.animate() at jquery.js:18f.extend.dequeue() at jquery.js:16f.fn.extend.queue() at jquery.js:16e.extend.each() at jquery.js:16e.fn.e.each() at jquery.js:16f.fn.extend.queue() at jquery.js:16f.fn.extend.animate() at jquery.js:18f.each.f.fn.(anonymous function)() at jquery.js:18jq.keydown.e() at global.js:343f.event.handle() at jquery.js:17f.event.add.i.handle.k() at jquery.js:16

  • BP 1.5
  • Mailpress 5.1.1
  • WP 3.2.1
  • BuddyPress Default 1.5 skin

Change History (1)

#1 @boonebgorges
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

The problem appears to be that Mailpress is reloading jQuery. In the Mailpress widget, make sure you check that jquery is preloaded. Then everything works fine.

My opinion is that this is not a bug. The reason why Mailpress offers the "preloaded" option in the widget is to account for themes where jquery is not loaded. Since bp-default *does* load jQuery, that seems to be the very purpose of the "preloaded" checkbox. If anything, Mailchimp could be a bit more sophisticated about the way it enqueues jQuery for the widget; it currently does it in the widget itself, when it should really be doing it on the wp_enqueue_scripts action, using http://codex.wordpress.org/Function_Reference/is_active_widget or something like that.

Note: See TracTickets for help on using tickets.