Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 13 years ago

Last modified 8 years ago

#3626 closed defect (bug) (fixed)

bp-default's search posts does not work when any of the directory(BP) pages are set as home page

Reported by: sbrajesh's profile sbrajesh Owned by:
Milestone: 1.6 Priority: normal
Severity: normal Version: 1.5
Component: Templates Keywords: needs-testing needs-patch
Cc: sbrajesh

Description

On a Standard wordpress(not multisite) install, if we set one of the directory pages as site home(e.g members directory or activity page as site home page), The posts search does not work. If you select the posts from search drop down and type anything to search, the search page will not be loaded.

If you change the home page from from directory pages to something else(Say any non bp wordpress page), the search works.

I was testing this on r5190
I was working on one of the theme and found this issue so though to report here. Any clue ?

Change History (4)

#1 @boonebgorges
13 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 1.6

Confirmed. The problem is that the form is submitted to bp_get_root_domain(), but bp_get_root_domain() is not always the posts page.

This points to a potentially larger problem, which is that if you switch the front page to something other than Latest Posts, there is no longer a way to view the latest posts. So it's not even clear what we would redirect the search request to.

#2 @djpaul
13 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5225]) Fix search routing when blog posts aren't displayed on the front of a site. Fixes #3626

#3 @djpaul
13 years ago

(In [5226]) Fix search routing when blog posts aren't displayed on the front of a site. Fixes #3626

#4 @DJPaul
8 years ago

  • Component changed from Appearance - Template Parts to Templates
Note: See TracTickets for help on using tickets.