Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 11 years ago

Last modified 11 years ago

#3624 closed defect (bug) (no action required)

Duplicated groups

Reported by: livemeorg's profile livemeorg Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Groups Keywords: reporter-feedback
Cc:

Description

In all groups page,arrangement is recent activity,show group is very strange that I can see there are four groups are the same!You can see this img :https://picasaweb.google.com/lh/photo/HcN6eb_nkQw1o2lqUOSVDg?feat=directlink

Attachments (2)

123.png (10.0 KB) - added by livemeorg 13 years ago.
four groups are the same
four groups are the same02.png (76.3 KB) - added by livemeorg 13 years ago.
four groups are the same02

Download all attachments as: .zip

Change History (13)

@livemeorg
13 years ago

four groups are the same

@livemeorg
13 years ago

four groups are the same02

#1 @johnjamesjacoby
13 years ago

  • Milestone changed from Awaiting Review to 1.6

Never seen this before. Any more information you can provide about your installation and steps to reproduce this would be helpful.

#2 follow-up: @DJPaul
13 years ago

Is the group in your database once or four times? Are the group URLs the same?

#3 @DJPaul
13 years ago

  • Keywords reporter-feedback added

#4 in reply to: ↑ 2 @livemeorg
13 years ago

Replying to DJPaul:

Is the group in your database once or four times? Are the group URLs the same?

The group in my database once!Yes,the group URLs are the same.It's so strange!

#5 @r-a-y
13 years ago

Do you have any plugins interfering with the group loop or groups in any way? If so, try deactivating those plugins.

Interesting that the last active timestamp is different for the duplicated groups.

#6 @r-a-y
13 years ago

  • Summary changed from A strange problem about the groups to Duplicated groups

#7 @boonebgorges
12 years ago

  • Milestone changed from 1.6 to Future Release

Moving to future release, pending reporter feedback.

#8 @boonebgorges
12 years ago

I just received this email:

Stumbled across this bug and have some info for you:

http://buddypress.trac.wordpress.org/ticket/3624

I had exactly the same issue. One entry in DB, several showing from groups-loop.php

For me, the problem was that I had multiple entries in wp_bp_groups_groupsmeta table. I deleted them and everything worked.

I worked out they were being caused by DB Cache Reloaded Fix - a DB caching plugin I had enabled. I disabled it, and all is good.

Needs more investigation, but it's a promising lead.

#9 @imath
11 years ago

Since 1.8.1, as query uses a DISTINCT keyword, this bug might have disapeared...
http://buddypress.trac.wordpress.org/browser/tags/1.8.1/bp-groups/bp-groups-classes.php#L356

#10 @boonebgorges
11 years ago

  • Resolution set to invalid
  • Status changed from new to closed

I'm going to agree with imath. livemeorg, if you can reproduce on the latest version of BP, please reopen with details. Thanks!

#11 @boonebgorges
11 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.