Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

Last modified 5 years ago

#3575 closed defect (bug) (fixed)

Spinners inside buttons - IE9 - not compatible view

Reported by: xeqta Owned by:
Milestone: 1.5 Priority: normal
Severity: normal Version: 1.5
Component: Templates Keywords: ui-feedback has-patch
Cc:

Description

Spinners in those buttons isn't showing up. (testbp.org)

Screenshot added.

Attachments (2)

screenshot.jpg (19.9 KB) - added by xeqta 10 years ago.
3575.01.patch (1021 bytes) - added by r-a-y 10 years ago.

Download all attachments as: .zip

Change History (9)

@xeqta
10 years ago

#1 @johnjamesjacoby
10 years ago

  • Component changed from Core to Theme
  • Keywords needs-patch ui-feedback added
  • Milestone changed from Awaiting Review to 1.5

Anyone with easy access to IE9 care to patch, quickly?

#2 @DJPaul
10 years ago

I can't fix it, but can confirm issue (tested at work on IE9). Graphic seems to appear, as the button goes wider, but no spinner visible.

#3 @akash_bug
10 years ago

Yes ajax spinners are not visible.......
can we have some exeptions for ie9...@djpaul

@r-a-y
10 years ago

#4 @r-a-y
10 years ago

  • Keywords has-patch added; needs-patch removed
  • Version set to 1.5

Just tested in IE9 on testbp.org.

The problem is the filter declaration; it's interfering with the background-image.

01.patch removes the filter when the loading class is added to the submit button. However, by doing this, we lose the gradient albeit temporarily.

Another solution can be found here:
http://stackoverflow.com/questions/7028524/using-the-css-filter-property-for-ie-7-8-for-a-gradient-along-with-a-background

#5 @DJPaul
10 years ago

Thanks for investigating; I recall we had a similar problem with the header gradient on IE with something else (we ended up not having a gradient on the header). Let's go with your patch; I dislike filter workarounds almost as much as I dislike adding a div to fix IE-specific problems :)

#6 @djpaul
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5154]) Fix loading spinners in buttons for IE. Fixes #3575, props r-a-y

#7 @DJPaul
5 years ago

  • Component changed from Appearance - Template Parts to Templates
Note: See TracTickets for help on using tickets.