Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 11 years ago

Last modified 8 years ago

#3566 closed defect (bug) (worksforme)

One Column, No Sidebar template not applied to Component Page Directories (Members, Forums, Groups, Activity)

Reported by: qrahaman's profile qrahaman Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Templates Keywords:
Cc:

Description

This bug has been confirmed by @mercime. Changing from the default template to One Column, No Sidebar only works for new pages. The template will not be applied to Members, Forums, Groups, Activity pages. I'm on the latest version of Wordpress, multisite enabled, BP 1.5 Beta 3. I left the ticket priority to "normal" but for me, it's critical functionality. Thanks.

Change History (6)

#1 @DJPaul
13 years ago

  • Milestone changed from Awaiting Review to 1.6

It won't, because BuddyPress' templates are built on the original sidebar templates. While this would be possible to address by putting in a lot of logic in most of BuddyPress' template files, that would be a pretty messy solution and it is too late in the dev cycle to consider it. This will have to wait until BuddyPress 1.6+ when we're going to be changing how the templating works.

#3 @boonebgorges
12 years ago

  • Milestone changed from 1.6 to Future Release

We're not changing the way templating works in BP 1.6. This ticket might be resolved alongside the broader issue of theme compatibility. See #3741

#4 @chrisclayton
12 years ago

  • Component changed from Core to Theme

#5 @r-a-y
11 years ago

  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Theme compat does indeed address this. (Edit - not for bp-default themes though.)

Check out BP 1.7 in trunk.

Last edited 11 years ago by r-a-y (previous) (diff)

#6 @DJPaul
8 years ago

  • Component changed from Appearance - Template Parts to Templates
Note: See TracTickets for help on using tickets.