Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 7 years ago

Last modified 7 years ago

#3548 closed enhancement (duplicate)

Notifications Personal/Private Activity Stream

Reported by: nahummadrid Owned by:
Milestone: 1.9 Priority: normal
Severity: normal Version:
Component: Toolbar & Notifications Keywords:
Cc:

Description

as referenced here. http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/is-there-a-way-to-keep-a-notifications-stream-or-history/

Was thinking it would be very useful to keep a history(activity stream) of all notifications. Currently notifications' landing pages take you to the source pages, so there's not history trail to refer back to.

this would also serve as a nice place to house other WP notifications like comment approvals, publishing of your posts, comments subscriptions, plugin update alerts, etc, and it would also be nice to include a record of all the BP public notices published by the admin.

I just imagine its making it easier for the user to have a log of something like this to always easy access to, currently i think things like friend requests get lost if the user doesn't act on it the first time they view a notfication.

Change History (4)

#1 @boonebgorges
10 years ago

  • Milestone changed from Awaiting Review to Future Release

Agreed that this would be nice. Patches welcome!

#2 @boonebgorges
10 years ago

  • Keywords needs-patch added

#3 @r-a-y
7 years ago

  • Keywords needs-patch removed
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Notifications were split into its own component in BP 1.9, which adds "mark as read" functionality. So it is possible to keep a history of read notifications now.

Marking as a duplicate of #5148.

#4 @r-a-y
7 years ago

  • Milestone set to 1.9
Note: See TracTickets for help on using tickets.