Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#3527 closed defect (bug) (fixed)

Friends feed only shows displayed user's activity

Reported by: r-a-y's profile r-a-y Owned by:
Milestone: 1.5 Priority: normal
Severity: normal Version:
Component: Activity Keywords: has-patch
Cc:

Description

The RSS feed for a displayed user's friends only shows the activity of the displayed user.

eg. /members/admin/activity/friends/feed/

Attached patch changes the parameters to scope=friends instead of trying to set the user_id parameter. Patch also fixes the URL in the <link> tag.

---

I should note that this bug does not occur on testbp.org.

My test setup uses a members root slug of /community/members/. Perhaps that might be the cause of the bug? Can anybody duplicate this?

Anyway, the proposed patch doesn't do any harm.

Attachments (1)

3527.01.patch (1.5 KB) - added by r-a-y 13 years ago.

Download all attachments as: .zip

Change History (3)

@r-a-y
13 years ago

#1 @johnjamesjacoby
13 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5065]) Update bp-activity-friends-feed.php. Props r-a-y for original patch. Fixes #3527.

#2 @johnjamesjacoby
13 years ago

  • Milestone changed from Awaiting Review to 1.5
  • Version 1.5 deleted
Note: See TracTickets for help on using tickets.