Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 8 years ago

Last modified 4 years ago

#3489 closed defect (bug) (fixed)

Incorrect hook in default theme forums/single/forum.php

Reported by: Jonnyauk Owned by:
Milestone: 1.5 Priority: normal
Severity: normal Version:
Component: Templates Keywords: has-patch commit
Cc: contact@…

Description

Further ticket 3484 I've been looking over the default theme files and noticed that there seems to be an incorrect hook in forums/single/forum.php

Inside the container divs there is the hook 'bp_before_group_home_content' - should this be bp_before_directory_forums_content to match the hook 'bp_after_directory_forums_content'?

Attachments (1)

patch.diff (1.3 KB) - added by Jonnyauk 9 years ago.

Download all attachments as: .zip

Change History (8)

@Jonnyauk
9 years ago

#1 @r-a-y
9 years ago

Correct me if I'm wrong, but I don't believe those templates (forum/single/*.php) are even used at the moment.

#2 @Jonnyauk
9 years ago

Ah - I'm fairly new to the BP theme file system, so apologies if this file is not used!

Options are then to either remove the file (one less for theme designers to worry about!), or leave it in and correct hook as per patch attached.

#3 @Jonnyauk
9 years ago

  • Cc contact@… added
  • Component changed from Core to Theme

#4 @johnjamesjacoby
8 years ago

  • Keywords has-patch commit added; 2nd-opinion removed

Confirmed. Moving to 1.5 Milestone.

#5 @johnjamesjacoby
8 years ago

  • Milestone changed from Awaiting Review to 1.5

#6 @boonebgorges
8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5050]) Corrects hook name in forums/single/forum.php. Fixes #3489. Props Jonnyauk

#7 @DJPaul
4 years ago

  • Component changed from Appearance - Template Parts to Templates
Note: See TracTickets for help on using tickets.