Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 9 years ago

#3478 closed defect (bug) (fixed)

Can't display multiple checkboxes in xprofile fields

Reported by: ptahdunbar Owned by:
Milestone: 1.5 Priority: normal
Severity: normal Version: 1.5
Component: Core Keywords: has-patch
Cc:

Description

When creating a multi-checkbox field in BuddyPress, it only displays the first option.

This is due to a $count variable resetting the parent $count value within a nested for loop in bp_get_the_profile_field_options().

Patch creates a unique name for the nested count variable, fixes the bug so it actually displays all the fields.

Attachments (1)

ticket.3478.diff (614 bytes) - added by ptahdunbar 9 years ago.

Download all attachments as: .zip

Change History (3)

#1 @DJPaul
9 years ago

  • Milestone changed from Awaiting Review to 1.5

Confirmed, thanks for the patch

#2 @djpaul
9 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4975]) Fix display of multiple checkboxes in profile fields. Fixes #3478, props ptahdunbar

Note: See TracTickets for help on using tickets.