Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#3457 closed defect (bug) (no action required)

Site Activity page ajax not working

Reported by: imjscn's profile imjscn Owned by:
Milestone: 1.5 Priority: normal
Severity: normal Version: 1.5
Component: Activity Keywords:
Cc: jennysong.ss@…

Description

I'm testing bp1.5 with wp3.2.1, use default theme, no other plugin.
After the activity page loaded, can't switch to other tabs. The loading indicator is running forever. If refresh the activity page, can get the tab that previously clicked.

Attachments (1)

3457.01.patch (478 bytes) - added by boonebgorges 13 years ago.

Download all attachments as: .zip

Change History (12)

#1 @DJPaul
13 years ago

Do you mean on a URL such as http://testbp.org/activity ? Can you recreate on testbp? It seems to work for me.

#2 @imjscn
13 years ago

this is the current testing site.
http://bp15.meshup.tk/activity/

Previously I installed bp1.3 on another hosting site, also had this problem.

#3 @boonebgorges
13 years ago

  • Milestone changed from Awaiting Review to 1.5

I'm able to reproduce the problem on your site, but not on any other installation of BuddyPress.

The strange thing is that when I inspect the AJAX request with Firebug, it seems to be getting the proper response back. That suggests that something strange is happening with the javascript that handles the response. The markup looks correct, so I'm at a bit of a loss.

Do you have any other plugins installed? Have you made any modifications to the theme?

Also, I noticed while looking at this that there seems to be a small issue with the way that bp_activity_request() arguments are sent in this case. (I doubt it's related to the issue at hand, but it should probably be fixed anyway.) Patch attached. DJPaul, can you verify that I'm not crazy?

#4 @imjscn
13 years ago

Previously when bp1.3 got this problem, that was on another site with lots of plugins. Now bp1.5 had this problem when it was brand newly installed without any other plugin, and default theme.
Since nobody else has this problem, let me install it on another host, to see if it is a server setting problem. I will report back soon.

Version 0, edited 13 years ago by imjscn (next)

#5 @imjscn
13 years ago

Now I installed bp1.5 on my own site which is on another server, it works fine. Seems only this testing site's problem.

#6 @boonebgorges
13 years ago

Thanks for checking it out, imjscn. It still doesn't really make sense to me - I'm not sure how the server settings could affect the way that the AJAX response is handled (a client-side action). Leaving this ticket open for a bit, so that DJPaul can check out my patch, and maybe chip in with any thoughts he might have.

#7 @DJPaul
13 years ago

You could use a http packet sniffer to see exactly what response is being returned on each server, and see if there's a formatting or character encoding difference. Other than that, it could be a client caching issue (your other server will have a different URL so won't use the cache from the first).

#8 @boonebgorges
13 years ago

DJPaul - How about 3457.01.patch?

#9 @DJPaul
13 years ago

Yep, that's not needed. Good spot.

#10 @r-a-y
13 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Problem is a plugin. In the AJAX response is some javascript for Google Analytics.

Might be good to list the plugin or code snippet used for GA.

#11 @boonebgorges
13 years ago

(In [4956]) Don't pass too many arguments to bp_activity_request() in bp-default javascript. See #3457

Note: See TracTickets for help on using tickets.