Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 12 years ago

#3448 closed defect (bug) (worksforme)

Post and delete button issue

Reported by: xeqta's profile xeqta Owned by: xeqta's profile xeqta
Milestone: 1.5.2 Priority: trivial
Severity: trivial Version:
Component: Core Keywords:
Cc: xeqta

Description

I noticed two small things today on testbp.org using Safari 5.1.

1: This only happens the first time you post something from your profile. Just after clicking the post button and the spinner is running you see there's a small area of the border (around the button, top left) which is missing. A small graphic issue but something you notice.

2: If you post an update and just after deletes the update, the delete button becomes narrow for just a second while the spinner is running.

Attachments (1)

Screenshot.jpg (189.3 KB) - added by xeqta 13 years ago.

Download all attachments as: .zip

Change History (12)

#1 @DJPaul
13 years ago

  1. Do you mean e.g. on a brand new user's profile?
  2. I can't recreate, but I'm not sure I fully understand. Please would you clarify how to recreate? Thanks.

#2 @xeqta
13 years ago

I tested both on my own profile: http://testbp.org/members/xeqta/

Issue 1 (step by step)

  • Goto profile
  • Fill out update textfield and click post (don't move mouse)

(A small part of the border is broken on my screen)

Issue 2 (step by step)

  • Just after completing the 2 steps from Issue 1, press delete.

(The button somewhat collapse when the spinner is running)

Not sure it's a problem on any other browsers than Safari.

#3 @xeqta
13 years ago

2:
Actually, there's something wrong with most buttons when the spinner is running in Safari. The spinner overlaps the text inside the button. (Safari)

#4 @johnjamesjacoby
13 years ago

  • Milestone changed from Awaiting Review to 1.5
  • Version 1.5 deleted

Probably the JS firing out of order. Confirmed.

#5 @boonebgorges
13 years ago

  • Keywords reporter-feedback added; xeqta removed
  • Priority changed from normal to trivial
  • Severity changed from normal to trivial

I'm afraid I still don't understand the problem. jjj or xeqta, can you be specific? There seem to be about three or four issues being reported here, but I can't really reproduce any of them (or at least I can't recognize that I am reproducing it).

@xeqta
13 years ago

#6 @xeqta
13 years ago

  • Keywords reporter-feedback removed

Just tested this again. I have attached a screenshot which shows where the piece of the border is missing while the spinner is running and the steps to get there.

(Used Safari 5.1, testbp, iMac)

#7 @xeqta
13 years ago

I cannot generate the second issue anymore with the delete link. (seems like it has been accidently solved) so there's only 1 issue in this ticket now.

#8 @johnjamesjacoby
13 years ago

Delete button narrowness happens when you click the button and then mouse off of it before it disappears.

#9 @boonebgorges
13 years ago

xeqta - Weird. I can't reproduce it - Safari 5.1, testbp.org. Very strange.

Can't manage to reproduce the delete button problem either. jjj, is this cross-browser?

#10 @boonebgorges
13 years ago

  • Milestone changed from 1.5 to 1.5.1

I still can't reproduce it. If jjj, or someone else who is able to reproduce the problem, can come forward with a patch, we'll put it back in the 1.5 milestone. But for the moment let's get it out of here.

#11 @boonebgorges
12 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Still can't reproduce, so I'm closing this. If anyone can give steps to reproduce, please feel free to reopen and provide those steps.

Note: See TracTickets for help on using tickets.