Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

#3446 closed defect (bug) (fixed)

Error while promoting user to group mod/admin

Reported by: slaFFik Owned by: slaFFik
Milestone: 1.5 Priority: normal
Severity: major Version: 1.5
Component: Extended Profile Keywords: has-patch
Cc:

Description

While working with BP Default Data I found a problem in promoting users in group. Here is the full text of an error:
Notice: Undefined index: Name in Z:\home\ovi\trunk\wp-content\plugins\buddypress\bp-core\bp-core-classes.php on line 157
Warning: Cannot modify header information - headers already sent by (output started at Z:\home\ovi\trunk\wp-content\plugins\buddypress\bp-core\bp-core-classes.php:157) in Z:\home\ovi\trunk\wp-includes\pluggable.php on line 934

I have WP_DEBUG enabled and rather severe php rules of displaying errors.

Attachments (1)

fix_xprofile_fullname_field.patch (553 bytes) - added by slaFFik 10 years ago.

Download all attachments as: .zip

Change History (7)

#1 @slaFFik
10 years ago

forgot to add - using the very latest BP trunk version.

#2 @slaFFik
10 years ago

But users are promoting and demoting - I just see this error, going back in the browser and reloading the page.

#3 @slaFFik
10 years ago

  • Severity changed from normal to major

Ok, here is the description of an error. It tries to get full_name of that user we are working with. It uses the field name called Name (main undeletable field) - and I don't have it in the DB - I have Base instead (I just renamed it).
So the problem is that this option:

$bp->site_options['bp-xprofile-fullname-field-name']

is not updated when we are renaming the field with ID = 1 (I have tested this).

Working with the patch...

Last edited 10 years ago by slaFFik (previous) (diff)

#4 @slaFFik
10 years ago

  • Component changed from Groups to XProfile
  • Keywords has-patch added; needs-patch removed

Attached is a quick patch that fixes this problem.

#5 @DJPaul
10 years ago

  • Milestone changed from Awaiting Review to 1.5

#6 @djpaul
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4939]) Update the site options when xprofile default group or names are changed in xprofile admin. Fixes #3446, props slaFFik

Note: See TracTickets for help on using tickets.