Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 12 years ago

Last modified 8 years ago

#3436 closed defect (bug) (worksforme)

multisite + buddypress, admin bar doesn't show dshaboard link, and another bug

Reported by: cupid4's profile cupid4 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Toolbar & Notifications Keywords:
Cc:

Description

I have been testing bp 1.5 on multisite install, and found this two problems,

1 - the (dashboard) menu link with 3 sub-menu in admin bar doesn't show when you sign in and in buddypress pages, like it used to in last version, it just show up if you are visiting your blog page.

2 - and I don't know if that make no sense, but one of my blogs, when I hover over the admin bar where it say: blog authors: it show me the two authors avatars normally, but the links are like following:

http://mywebistename.com/for-love/5-revision-4/46/Author1/
http://mywebistename.com/for-love/5-revision-4/46/Author2/

the funny thing is that " for love " is the name of first post in this blog! so I have no idea why it show this strange combination instead of members pages like it used to do before I updated to 1.5 , and in other blogs in the same multisite this authors links are working without this problem.

I think the first error can be reproduced easily for you, but don't know what about the second, just hope my report will help fix anything :)

Change History (13)

#1 @boonebgorges
13 years ago

  • Milestone changed from Awaiting Review to 1.5

Can't test at the moment, but this should be checked.

#2 @wdfee
13 years ago

  • Keywords 2nd-opinion added

tried to check this

1 - dashboard link is not visible for subscribers, in fact they can't login to wp-admin, but it's visible from author role and above. I think that's good and should be that way.

but the rest is completely different for me:
there are no extra buddypress pages on the subblog, all buddypress links link to the buddypress pages on root install. I'm not sure if there should be an extra buddypress on the subblog.

There are no author links in the admin bar anymore. I'm not sure if they disappeared or it could be a configuration on my site. I don't use this install as Wordpress blog and just did some articles only for testing this issue.

#3 @wdfee
13 years ago

Set define ( 'BP_ENABLE_MULTIBLOG', true ); in wp-config.php again (I removed that once). Now I have an extra the buddypress admin menu on the subblog, but the buddypress pages are still from root blog (the settings page only has root pages to choose from).

#4 @wdfee
13 years ago

think you have to create subnetworks (http://wpmututorials.com/news/new-features/multiple-buddypress-social-networks/) for a seperate buddypress, not subblogs - or am I wrong?

#5 @DJPaul
13 years ago

  • Keywords 2nd-opinion removed
  • Milestone changed from 1.5 to Future Release

I can't recreate either issue. I agree with wdfee that the dashboard link behaviour for the buddybar is working correctly (authors + up).

cupid4, your "for-love" link issue; you say it works on another site. On the site where it is broken, if you create a new site and add authors, are the links incorrect on that site?

#6 @DJPaul
13 years ago

  • Milestone changed from Future Release to Awaiting Review

#7 @DJPaul
13 years ago

  • Keywords reporter-feedback added

#8 @johnjamesjacoby
12 years ago

  • Milestone changed from Awaiting Review to 1.5
  • Version 1.5 deleted

Anyone have time to test this before 1.5?

#9 @johnjamesjacoby
12 years ago

  • Component changed from Core to Admin/Buddy Bars

#10 @cupid4
12 years ago

  • Keywords reporter-feedback removed

Sorry for not coming here earlier, I never got a notification e-mail for this ticket, and just found it now by chance.
I created a new blog in multsite with the same user, and the author link is working, I even tried writing a post with same name as first blog and I changed permalink and so on but the problem was never reproduced in the new blog, so I suppose it's so rare problem to appear as there are no other reports like mine.
I solved this problem for myself by importing the old blog to a fresh blog and the author link is working well this way.

#11 @cupid4
12 years ago

And for the first matter, you really didn't get the picture, I meant that in BP 1.2.9 , there used to be a link in buddybar named: "my sites" and if you hover over it it show you your sites and again hovering over one site of it, it show you links to dashboard, write a new post or manage comments, it was very helpful feature.

and that what disappeared in 1.5, it was easier for user to have his blogs always in hand, instead of going to the blog itself and then click dashboard, got my idea?

#12 @johnjamesjacoby
12 years ago

  • Milestone 1.5 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

The "My Blogs" link was changed early in the 1.5 dev cycle because of the query performing poorly and the blogs component seeing some changes in how it works.

Closing since reporter confirms issue is no longer happening.

#13 @DJPaul
8 years ago

  • Component changed from General - Toolbar/BuddyBar to Toolbar & Notifications
Note: See TracTickets for help on using tickets.