Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 9 years ago

#3423 closed defect (bug) (no action required)

Can not activate BuddyPress on the second blog on WordPress multi-site (subdirectory)

Reported by: lightcapturer Owned by:
Milestone: 1.5 Priority: normal
Severity: normal Version: 1.5
Component: Core Keywords:
Cc:

Description

I have tried several times to enable BuddyPress, both of which I downloaded from the trunk or from the tags, on the second blog on WordPress multi-site (subdirectory), but not being successful. Here is the statement after I click the Save & Next when updating BuddyPress: "You do not have sufficient permissions to access this page."

Change History (12)

#1 @DJPaul
9 years ago

  • Milestone changed from Awaiting Review to 1.5

I've not tested yet but this should be checked

#2 @valuser
9 years ago

Have encountered same. But have carried on. bp 4943. BP Root Blog on subdirectory - still appears to function correctly.

#3 @valuser
9 years ago

scratch my comment above. The behavior is just as @ lightcapturer describes. press forum set-up (new or existing) and you get "You do not have sufficient permissions to access this page." message v.4963

#4 @valuser
9 years ago

it just will not produce a viewable forums directory page. http/mysite/subsite/forums/ reverts to http/mysite/subsite/.

but somehow it does in trunk 4947 ???

#5 follow-up: @DJPaul
9 years ago

lightcapturer - please clarify how you are "[activating BP] on the second blog on WordPress multi-site (subdirectory)". To activate BP, I have to go to Network Admin and activate it Network-wide. To make it work on a site with ID != 1, I have to set BP_ROOT_BLOG in wp-config.php. If you can provide step-by-step instructions to make sure we recreate in the same way, that will help. Thanks.

#6 @DJPaul
9 years ago

  • Keywords reporter-feedback added

#7 @wpmuguru
9 years ago

I've been working with someone testing http://wpmututorials.com/news/new-features/multiple-buddypress-social-networks/ & defining BP_ROOT_BLOG to a subsite works as of late last week.

#8 @valuser
9 years ago

Still getting "You do not have sufficient permissions to access this page" using trunk 4986 with bbpress 1.03 in bp-forums folder.

wp-config.php

etc

define('WPLANG', );
define('BP_ENABLE_MULTIBLOG', true );
define ( 'BP_ROOT_BLOG', 2 );
/

  • For developers: WordPress debugging mode. *
  • Change this to true to enable the display of notices during development.
  • It is strongly recommended that plugin and theme developers use WP_DEBUG
  • in their development environments. */

define('WP_DEBUG', false);
define('WP_ALLOW_MULTISITE', true);
define( 'MULTISITE', true );
define( 'SUBDOMAIN_INSTALL', false );
$base = '/';
define( 'DOMAIN_CURRENT_SITE', 'mysite.com' );
define( 'PATH_CURRENT_SITE', '/' );
define( 'SITE_ID_CURRENT_SITE', 1 );
define( 'BLOG_ID_CURRENT_SITE', 1 );
define('BP_DISABLE_ADMIN_BAR', true);
/* That's all, stop editing! Happy blogging. */

etc

Also, if relevant, in trunk 4947 it set up the forum directory page, but you can't make a new topic. as the page loads you can see the new topic set-up, but that goes away as page load completes. Then clicking new topic button does nothing. Subsequent trunks didn't get this far. May be meaningless.

Last edited 9 years ago by valuser (previous) (diff)

#9 @wpmuguru
9 years ago

When you have

define('BP_ENABLE_MULTIBLOG', true );

then

define ( 'BP_ROOT_BLOG', 2 );

is ignored. With BP_ENABLE_MULTIBLOG every blog is the root blog.

Last edited 9 years ago by wpmuguru (previous) (diff)

#10 @valuser
9 years ago

Thanks. Sorry for wasting time. v 4988 working as expected.

#11 in reply to: ↑ 5 @lightcapturer
9 years ago

  • Keywords reporter-feedback removed

Replying to DJPaul:

This is a ticket that I created 2 weeks ago. At that time indeed I found the problem, failed to activate BuddyPress on WordPress multisite (subdirectory). The steps that I do is exactly as you described, with BP_ROOT_BLOG setting in wp-config.php. Some days I let it up and then I try again. Surprisingly, it worked by itself. And I did not make any changes on the settings. Until now I do not know what made ​​it work. The problem now is gone by itself.

Even now I'm finishing a BuddyPress project on a subdirectory (just a reworking with BP 1.5).

While, my current problem is only this ticket.

I'm sorry for the delay to reply.

#12 @boonebgorges
9 years ago

  • Resolution set to invalid
  • Status changed from new to closed

I'm going to close the ticket, since lightcapturer says that it's been cleared up.

Note: See TracTickets for help on using tickets.