Skip to:

Opened 13 years ago

Closed 13 years ago

#3418 closed enhancement (fixed)

Probable Inconsistency in the name of Actions created by BP_Component class

Reported by: sbrajesh's profile sbrajesh Owned by:
Milestone: 1.5 Priority: normal
Severity: normal Version: 1.5
Component: Core Keywords: has-patch
Cc: sbrajesh


Hi Core Devs,
First of all, I want to thank you all for the BP_Component class which takes a lot of pain(or may be writing code) out of the plugin development. It's a major improvement.

I have found something which seems more like a typeo. Earlier we had actions like "bp_groups_setup_global" or so on in the format "bp_componentId_actionname", In bp 1.3, The BP_Component calls it like

do_action( 'bp_' . $this->id . 'setup_globals' );
That means, for group component, the setup global action will be "bp_groupssetup_globals" not the "bp_groups_setup_global".

The same thing is for a few other actions in the class. Just wanted to know if it is intentional or some type in the core.

Here is a patch attached to update that if you consider this change worthy.


Attachments (1)

update_core_actions.patch (1.4 KB) - added by sbrajesh 13 years ago.

Download all attachments as: .zip

Change History (3)

#1 @DJPaul
13 years ago

  • Milestone changed from Awaiting Review to 1.5

#2 @djpaul
13 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4912]) Correct name of certain actions in BP_Component. Fixes #3418, props sbrajesh

Note: See TracTickets for help on using tickets.