Skip to:
Content

Opened 5 years ago

Closed 5 years ago

#330 closed defect (bug) (fixed)

Pagination in Blogs resulting in 404

Reported by: jmax123 Owned by:
Milestone: Priority: minor
Severity: Version:
Component: Keywords:
Cc:

Description

The problem is that instead of www.domain.com/blog/page/2 the "Next page" link points to www.domain./blog/blog/page/2 and this gives a 404 error.

  • Environment: I have no idea.
  • MU version and install options. MU 2.6.5 with subdirectories
  • BP version: Not sure but I think the first beta.
  • bbpress version: Haven't installed yet.
  • Browser: Not browser related
  • What theme are you talking about? Not theme related. Occurs on all user blogs
  • What have you done to investigate and narrow down the source of your problem? I checked all settings in the backend and upgraded WP mu. It was 2.5.3 before.

The problem is here: <?php posts_nav_link(' ', ('« Previous Page'), ('Next Page »')); ?>

  • Give us a sample of the error message: It's a 404 message
  • In some cases a link to your site would be helpful: http://blogi.ee/villu

The "Next page" link should be: http://blogi.ee/villu/page/2/ instead it's: http://blogi.ee/villu/villu/page/2/

Change History (2)

comment:1 burtadsit5 years ago

Yep. Paging of index posts is broke using wp's standard next_posts_link() and previous_posts_link() and a wp theme. For me using 'news' to generate an index of posts using bp_catch_uri( 'index', true ), the url is xxx.org/news/page/2/.

comment:2 apeatling5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r330

Note: See TracTickets for help on using tickets.