Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

#3191 closed defect (bug) (fixed)

Buddypress Top Nav Not Showing All Links on root pages

Reported by: benfremer's profile benfremer Owned by: djpaul's profile DJPaul
Milestone: 1.5 Priority: critical
Severity: Version: 1.5
Component: Core Keywords:
Cc:

Description

The top navigation doesn't work on the root blog on a fresh install... for non Buddypress pages(home page, Groups directory, members directory), only Groups, Forums and Log Out appear under My Account.

It shows up just fine in the Buddypress sections of the site though...like profiles, messages, etc.

Attachments (1)

tracHomepage.jpg (78.7 KB) - added by benfremer 11 years ago.
Screenshot

Download all attachments as: .zip

Change History (12)

@benfremer
11 years ago

Screenshot

#1 @benfremer
11 years ago

  • Version set to 1.3

#2 @DJPaul
11 years ago

Are the components activated in the BuddyPress wp-admin screen? I've seen issues with upgrades from 1.2 installs not activating previously-activated components

#3 @benfremer
11 years ago

To the best of my recollection, all components were activated (and definitely showing in the dropdown on other buddypress-pages). It looks like they just didn't/don't show in the dropdown menu on the root-blog-pages for some reason.

#4 @DJPaul
11 years ago

  • Milestone changed from Awaiting Review to 1.3
  • Priority changed from normal to critical

Looks like I unintentionally broke this in r4281. Confirmed on trunk.

#5 @DennisSmolek
11 years ago

if I delete the check for the user displayed and the path for the $user domain in activity that component shows on non BP pages.. I'm checking removing it on the other parts of that changeset..

#6 @DennisSmolek
11 years ago

Yeah, its the check for displayed_user on Non BP pages.. Removing the check stops the return and creates the menu item.

#7 @DJPaul
11 years ago

Removing those breaks something else, it's not a straightforward fix. I will be looking at it.

#8 @Dennissmolek
11 years ago

Also, the way this is working now, when viewing another users profile page, then clicking on My Account> Activity > anything, loads the activity of the users profile you are looking at.
If you changed the displayed_user info to is_user_logged_in it works, at least on my sandbox.

I dont know what else breaks otherwise I'd submit a patch for this.

#9 @djpaul
11 years ago

(In [4381]) Reverting r4281 (see #3191)

#10 @DJPaul
11 years ago

  • Owner set to DJPaul
  • Status changed from new to accepted

#11 @DJPaul
11 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

This appears to be working correctly now, as a result of the broken code being removed in r4381, and a correct approach taken in r4506

Note: See TracTickets for help on using tickets.