Skip to:
Content

Opened 8 years ago

Closed 8 years ago

#3154 closed enhancement (duplicate)

Recognize deactivated components in 1.2-1.3 upgrade

Reported by: boonebgorges Owned by:
Milestone: 1.5 Priority: normal
Severity: Version: 1.5
Component: Core Keywords: dev-feedback
Cc:

Description

1.3 deprecates bp-deactivated-components in favor of bp-active-components. In the setup wizard (as of r4203), only bp-active-components are used to pre-check the boxes on the Component step. Ideally, there would be an additional check for the old bp-deactivated-components, which keeps those boxes from being checked by default when coming from a 1.2 install. If there is going to be a new upgrade type as suggested in #3153, this could be rolled into it.

Change History (5)

#1 @cnorris23
8 years ago

  • Keywords dev-feedback added

Doing some digging around, but shouldn't we be using the $bp global here. This applies to #3153 a little as well, as there are a few spots where we duplicate work that has already been done. The $bp->active_components should already be set by the time the wizard needs it, and this would also solve the problem in this ticket. I'm hoping to play around with this and #3153 tonight, and just wanted some feedback to make sure I wasn't missing something.

#2 @boonebgorges
8 years ago

Hm, maybe you're right. This needs more testing :)

#3 @cnorris23
8 years ago

@boonebgorges I've got a patch on #3153 (attachment:3153.003.diff:ticket:3153) that fixes this ticket and #3153 and a few other things I found while trying to fix this and #3153.

#4 @DJPaul
8 years ago

This is a duplicate of #3153

#5 @DJPaul
8 years ago

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.