Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 13 years ago

#3118 closed defect (bug) (no action required)

Datebox datas are not translated on public profile

Reported by: chouf1's profile chouf1 Owned by:
Milestone: 1.5 Priority: normal
Severity: Version: 1.2.8
Component: Extended Profile Keywords:
Cc:

Description

the profile datebox should show a date in custom format.

on the edit tab, the date is correctly translated in the 3 select boxes.
But on the public profile page, the date output is in unix format mouth day, year (good in english but not in french)

i tried to add date_i18n, as found in the trunk. On the edit profile tab, the date is given correctly, but the output shows then the current date !

Attachments (3)

admin_settings.jpg (50.0 KB) - added by chouf1 13 years ago.
profile_edit_form.jpg (34.8 KB) - added by chouf1 13 years ago.
public_output.jpg (30.8 KB) - added by chouf1 13 years ago.

Download all attachments as: .zip

Change History (10)

#1 @DJPaul
13 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Front-end does and should match the site setting in Settings > General > Date Format. Changing that option should update the format everyone on your site.

@chouf1
13 years ago

#2 @chouf1
13 years ago

Last edited 13 years ago by chouf1 (previous) (diff)

#3 in reply to: ↑ description @chouf1
13 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to chouf1:

the profile datebox should show a date in custom format.

on the edit tab, the date is correctly translated in the 3 select boxes.
But on the public profile page, the date output is in unix format mouth day, year (good in english but not in french)

i tried to add date_i18n, as found in the trunk. On the edit profile tab, the date is given correctly, but the output shows then the current date !

#4 @chouf1
13 years ago

Things are not like you say Paul, view attachment please.

#5 @DJPaul
13 years ago

They are working correctly in trunk. I am not sure what commit fixed it, as it could have needed fixing in several places, but if you do not want to test trunk, you could try looking at this fix: http://trac.buddypress.org/ticket/2779

#6 @chouf1
13 years ago

I use BP 1.2.8 standard and don't want to use trunk.
I uploaded fresh files from 1.2.8 taged version (xprofiles-filters and bp-core-templatetags)
The original version does not display correctly.
Any of the time settings i choose give the same weird output

I applied the patches but nothing changed.

Aside, i see that both files in the actual 1.2.8 are not patched.

So what ?

#7 @DJPaul
13 years ago

  • Milestone changed from Awaiting Review to 1.3
  • Resolution set to invalid
  • Status changed from reopened to closed

I am closing this ticket as the issue has been fixed, and does work correctly, in trunk. If someone wants to port and verify the fixes for this into branch/1.2.x, perhaps it could get added into 1.2.9.

Note: See TracTickets for help on using tickets.