Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3085 closed defect (bug) (duplicate)

BP_DISABLE_ADMIN_BAR no longer works in BP1.2.8 + WP3.1

Reported by: ashleylaing's profile ashleylaing Owned by:
Milestone: 1.5 Priority: normal
Severity: normal Version:
Component: Core Keywords: reporter-feedback
Cc:

Description

I have just upgraded to WP 3.1 and BP 1.2.8. Yes, admin bar came back. So I added…

/* Remove the Admin bar */
define(‘BP_DISABLE_ADMIN_BAR’, true);

… tried it in both wp-config.php and bp-custom.php. Doesn’t appear to be working.

Has this worked for others?

Change History (5)

#1 @cnorris23
11 years ago

  • Keywords reporter-feedback added

Is this the BP admin bar, or the new WP admin bar that comes with WP 3.1?

#2 @cnorris23
11 years ago

  • Version set to 1.2.8

#3 @r-a-y
11 years ago

The BP Admin Bar and the WP Admin Bar are two separate... bars ;)
The WP admin bar was introduced in WP 3.1.

BP_DISABLE_ADMIN_BAR only disables the BuddyBar.

To disable the WP admin bar, you can simply add the following in your theme's functions.php:

add_filter( 'show_admin_bar', '__return_false' );

For discussion on the BP_DISABLE_ADMIN_BAR constant, see: #3084

#4 @boonebgorges
11 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #3084.

BP_DISABLE_ADMIN_BAR, strictly speaking, still does keep the BP admin bar from showing. It just so happens that you now need to do an extra step to disable the WP admin bar, as r-a-y outlines above.

#5 @johnjamesjacoby
11 years ago

  • Milestone changed from Awaiting Review to 1.5
  • Severity set to normal
  • Version 1.2.8 deleted

Moving closed ticket out of Awaiting Review.

Note: See TracTickets for help on using tickets.