Skip to:
Content

Opened 8 years ago

Closed 8 years ago

#3060 closed defect (bug) (fixed)

Can't navigate to group page after creation - Page not found

Reported by: jasonnathan Owned by:
Milestone: 1.5 Priority: normal
Severity: Version:
Component: Groups Keywords: close
Cc:

Description

Downloaded WP rev 17425 (current)
Downloaded BP rev 4028 (current)

1) Installed WP.
2) Changed ( to numeric ) & Checked permalinks work.
3) Installed & activated BP excluding Forums
4) Using default BP theme
5) Navigated to Groups.
6) Created a group - mygroup

  • after creation navigates to /groups/mygroup with a page not found error.

7) Navigated to Groups directory.
8) Clicked on mygroup

  • Page not found error.

No one seems to be saying anything about my tickets so I waited a few days after finding the error before posting this one. Hopefully someone will reply?

Attachments (1)

bp-groups-loader.php (12.2 KB) - added by jasonnathan 8 years ago.

Download all attachments as: .zip

Change History (13)

#1 @jasonnathan
8 years ago

Last edited 8 years ago by jasonnathan (previous) (diff)

#2 @jasonnathan
8 years ago

The problem is that it's not firing the default subnav screen function

http://example.com/groups/example-group

is suppose to be firing "groups_screen_group_home()" because the default subnav is "home" but it's not.

http://example.com/groups/example-group/home

Loads fine.
No one has this problem? Can't reproduce this? Am I the only one?

#3 @jasonnathan
8 years ago

Last edited 8 years ago by jasonnathan (previous) (diff)

#4 @jasonnathan
8 years ago

  • "My Groups" was showing even though user wasn't logged in and it wasn't his profile page. The problem was in the declaration of the sub-nav items. Corrected 'user_has_access' => bp_is_my_profile() to the subnav declaration as it was before
  • The default subnav slug is not set to home when is single item.

The problem is certainly a little deeper than this but this was a quick fix in _setup_globals()
Set the default action_variable[0] to 'home' if its empty
That part is not so much a fix, more of a hack.

Last edited 8 years ago by jasonnathan (previous) (diff)

#5 @jasonnathan
8 years ago

Well, I did yet another fresh install and everything seems to be working magically...

I still would've appreciate some sort of reply -> like the problem couldn't be replicated or something, anything.

This is the nth ticket and I'm sick of it all still being in the awaiting review status.

I done with contributions here - whether or not they are relevant.

Thanks for the great software!

#6 @boonebgorges
8 years ago

This software is maintained by a small group of unpaid volunteers. While we would like to attend to every ticket very shortly, sometimes it does not happen, because of the size of our community. Thanks for the bug report.

#7 @DJPaul
8 years ago

  • Milestone changed from Awaiting Review to 1.3
  • Resolution set to fixed
  • Status changed from new to closed

#8 @DJPaul
8 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Wrong button. Valid issue.

#9 @jasonnathan
8 years ago

I would've preferred if you didn't explain. I've been watching the tickets very closely this past two weeks. You changed ticket statuses for ones that came before and after mine. Even those that came the same time as mine.

Sadly, you were doing it all by yourself but for whatever reason you may have ignored mine, you did.

By the way, it will help if you corrected the typo I made with "bot" instead of "not"

#10 @SergeyBiryukov
8 years ago

  • Summary changed from Can't navigate to group page after creation - Page bot found to Can't navigate to group page after creation - Page not found

#11 @boonebgorges
8 years ago

  • Keywords close added

DJPaul - It sounds like this problem was fixed somehow http://trac.buddypress.org/ticket/3060#comment:5

Close?

#12 @DJPaul
8 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in a previous commit (can't track down where/when).

Note: See TracTickets for help on using tickets.