Skip to:

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2981 closed defect (bug) (fixed)

Change "loop_start/end" actions to "component_loop_start/end"

Reported by: r-a-y's profile r-a-y Owned by:
Milestone: 1.5 Priority: normal
Severity: normal Version:
Component: Core Keywords: dev-feedback has-patch


During each of the BuddyPress component loops, we have an action during the beginning and end of the loop.

However, only the activity, message thread and xprofile loops have a prefix.


The other components do not. Any reason why?
This would make it easier to do checks during each respective loop.


The only caveat of making such a change is any plugins taking advantage of the existing actions will need to update their plugins.

Attachments (1)

2981.001.patch (4.4 KB) - added by r-a-y 13 years ago.

Download all attachments as: .zip

Change History (3)

13 years ago

#1 @boonebgorges
13 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [3616]) Changes loop_start/loop_end actions to be component-specific. Fixes #2981. Props r-a-y

#2 @johnjamesjacoby
13 years ago

  • Milestone changed from Awaiting Review to 1.5
  • Severity set to normal
  • Version 1.5 deleted

Moving closed ticket out of Awaiting Review.

Note: See TracTickets for help on using tickets.