Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 13 years ago

#2962 closed defect (bug) (fixed)

No way to reassociate a page with bp components once the bp setup wizard is complete

Reported by: sbrajesh's profile sbrajesh Owned by:
Milestone: 1.5 Priority: normal
Severity: Version: 1.5
Component: Core Keywords:
Cc: sbrajesh

Description

Hi,
was just trying the current trunk r3543. To experiment, I chose all the components to setup on same page(wp 3.1 trunk sample page) (example www.example.com/sample-page/)and the bp wizard proceeded without any error. So, as all the components are setup on same page, none of the component will work properly. When you visit http://example.com/sample-page/ it will show as member directory but clicking on member page will redirect to the site home page. yes, the user sub menu(like edit profile works but you can not view the www.example.com/sample-page/admin/).
The other links as expected point to http://www.example.com/sample-page/admin/sample-page/sample-page/ [this is for my groups link]

Since all the components are set on sample-page.
There is no option in BuddyPress dashboard to change the settings after the setup wizard has run, neither you can reassociate it after deactivating/activating the buddypress again.

In my opinion, It can cause a lot of trouble for users who are not familiar with wordpress/buddypress.

What do you think? Probably providing a way to reassociate the page after the setup wizard has run can solve the issue .
possibly related ticket(but for disabling/enabling component by ray #2943)

Change History (1)

#1 @DJPaul
13 years ago

  • Milestone changed from Awaiting Review to 1.3
  • Resolution set to fixed
  • Status changed from new to closed

Boone added such a page recently (#3019).

Note: See TracTickets for help on using tickets.