Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2958 closed defect (bug) (no action required)

wp 3.03 login redirect

Reported by: thatmtnman's profile thatmtnman Owned by:
Milestone: 1.2.9 Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

Dear Buddy Press,

I am reporting a log in error when buddy press is enabled on a 3.03 WP site. This bug was documented by technical staff at Hostgator for me, with the only solution being to turn off Buddy Press. I am attaching the transcript below.

Hello Frank,

I have seen many issues with the admin login of WordPress sites. From my experience, it is always related to the .htaccess file for the site, or a plugin.

I know that files named "profile.php" are in some way used for the admin dashboard, so I searched for files named that on the site.

# find . -name 'profile.php'
./wp-content/plugins/buddypress/bp-themes/bp-default/members/single/profile.php
./wp-content/plugins/buddypress/bp-forums/bbpress/bb-templates/kakumei/profile.php
./wp-content/plugins/buddypress/bp-forums/bbpress/profile.php
./wp-content/themes/church_20/members/single/profile.php
./wp-admin/profile.php

The only plugin containing that file was "buddypress". For that reason, it was my first choice as a plugin to disable for testing. Luckily, it worked and I did not need to test disabling the other plugins.

I was unable to determine that what exactly in the buddypress plugin was causing the issue. It contains 87,000 lines of code, which is quite a lot to debug.

I am not sure what you should report the community. A quick Google search turned up a similar, but not the same issue that was never resolved:
http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/friend-request-wp-login-redirects/

Change History (3)

#1 @thatmtnman
11 years ago

I need to use Buddy Press so if someone can figure this out, that would be great!

#2 @DJPaul
11 years ago

  • Resolution set to invalid
  • Status changed from new to closed

As this is a support request, rather than a bug report, please post on http://buddypress.org/community/groups/how-to-and-troubleshooting/. We'll need more details, too -- you've not actually explained what the problem is, or how we can try to recreate it.

#3 @johnjamesjacoby
11 years ago

  • Milestone changed from Awaiting Review to 1.2.9
  • Severity set to normal

Moving closed ticket out of Awaiting Review.

Note: See TracTickets for help on using tickets.