Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

#2781 closed defect (bug) (fixed)

Buddypress cannot be activated if language is set in wp-config.php to sv_SE

Reported by: hixx's profile hixx Owned by:
Milestone: 1.5 Priority: normal
Severity: Version: 1.2.6
Component: Core Keywords:
Cc:

Description

I have tried this both locally in MAMP and at my webhotel and come to the same result:

Wordpress in Swedish: Installing Buddypress works fine but when activating it I get the message that I am not autorized to activate plugins. After this I loose all right everywhere and cannot even login to the backend. Buddypress never activates. Removing the folder buddypress under plugins restores Wordpress and the authentication issue. When changing from sv_SE to en_EN in wp-config.php, installation and activation of Buddypress works normal.

Change History (3)

#1 @r-a-y
11 years ago

I can't confirm this because I tested this awhile back with success (though it was with another language).

Do you have admin privileges to manage plugins?

Do you have problems activating other plugins or is it just BuddyPress when you use your localized Wordpress install?

Make sure the define in wp-config.php is like:

define ('WPLANG', 'sv_SE');

And ensure that your .mo and .po files are in /wp-includes/languages/.

Afterwards, try changing the language from Swedish to English on the "General > Settings" page in the WP admin area. Do you still have problems with activating plugins then?

#2 @r-a-y
11 years ago

Related: #2633.

Could something be broken in the localized, Swedish WP install?

Do we have any other similar reports from other WP-localized versions?

#3 @DJPaul
11 years ago

  • Milestone changed from Awaiting Review to 1.3
  • Resolution set to fixed
  • Status changed from new to closed

I believe this is related to #WP14024 and as such should work in trunk now BuddyPress loads properly with regards to the init hooks. Reopen if you can recreate this on trunk.

Note: See TracTickets for help on using tickets.