Skip to:
Content

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2685 closed defect (bug) (fixed)

xprofile_get_field_data() with checkboxes no longer working correctly

Reported by: r-a-y Owned by: johnjamesjacoby
Milestone: 1.2.7 Priority: blocker
Severity: Version: 1.2.6
Component: XProfile Keywords:
Cc:

Description

Change History (5)

comment:1 boonebgorges3 years ago

The problem arose with [3270], which applies maybe_unserialize() to the output of get_value_byid(). When xprofile_get_field_data() is called on a checkbox, it gets the value from get_value_byid(). The output of xprofile_get_field_data is then run through some formatting filters like kses. The problem is that while those filters could handle the old serialized string (which was then unserialized in the template tags), they don't know how to handle arrays.

Before reverting the change I want to talk to JJJ (who applied [3270]) to see if there's a good reason, other than preferring to use maybe_unserialize in one place instead of two.

comment:2 DJPaul3 years ago

  • Priority changed from major to blocker

comment:3 johnjamesjacoby3 years ago

  • Owner set to johnjamesjacoby
  • Status changed from new to assigned
  • Version set to 1.2.6

comment:4 johnjamesjacoby3 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [3390]) Fixes #2685 by reverting part of r3270 (branch)

comment:5 johnjamesjacoby3 years ago

(In [3391]) Fixes #2685 by reverting part of r3270 (trunk)

Note: See TracTickets for help on using tickets.