Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

#2658 closed defect (bug) (worksforme)

Forum page 3 prematurely created

Reported by: sadr's profile Sadr Owned by:
Milestone: 1.5 Priority: minor
Severity: Version:
Component: Forums Keywords: thread, page, reporter-feedback
Cc: Sadr

Description

Seems threads are prematurely adding a 3rd page, so before there's actually content to put on page 3 of a forum thread the page is created without content, making for invalid links when trying to go on to the 3rd page or when following the latest-reply link from the forum index.

Discovered on jmonkeyengine.org.

Change History (5)

#1 @pisanojm
12 years ago

Haven't read about this happening any where in the forums... perhaps table to 1.3 and get more information... could be theme/plugin related?

Looked through user "SADR" on board and couldn't find anything he was talking about related... i.e. no discussions related to this ticket.

#2 follow-up: @DJPaul
12 years ago

  • Keywords reporter-feedback added

A bug report is a bug report, regardless of source. I have been unable to verify or recreate this on a clean BP 1.2.6/1.2 branch install.

Sadr, please would you confirm your version numbers of WordPress and BuddyPress, and if possible, test this using the default theme. Any particular steps to recreate would be appreciated, too, thanks.

#3 in reply to: ↑ 2 @Sadr
12 years ago

  • Cc Sadr added

Replying to DJPaul:

A bug report is a bug report, regardless of source. I have been unable to verify or recreate this on a clean BP 1.2.6/1.2 branch install.

Sadr, please would you confirm your version numbers of WordPress and BuddyPress, and if possible, test this using the default theme. Any particular steps to recreate would be appreciated, too, thanks.

Sure. We're running the latest stable versions of both softwares:
WordPress 3.0.1, BuddyPress 1.2.5.2

Here is an overview of our custom changes:
https://docs.google.com/document/edit?id=1Va_TGJQdZZQM3AH2D6IPOx8tjoKbh3XNwf6soJG5qjE&authkey=CImhvegI&hl=en#

We've also got quite the amount of plugins installed, so if this can't be recreated on a clean branch, I'm guessing the problem is at our end. We'll soon be setting up a mirror-site for testing. Maybe I'll get around to looking more closely into this bug then.

p.s. if you're wondering who I am specifically, I'm Erlend Sogge Heggen as seen on the jmonkeyengine.org site.

#4 @nuprn1
12 years ago

sounds like group forum extras plugin is causing the issue - (depending on what subplugin is used - as there is a calc to jump to the #lastpost / page - bp_forum_extras_topic_last_post_link( $per_page = 15 ) )

contact me on my bp site etivite.com - and we can figure out the issue (what you have modified)

#5 @johnjamesjacoby
12 years ago

  • Milestone changed from 1.2.6 to 1.3
  • Resolution set to worksforme
  • Status changed from new to closed

Can't duplicate it on vanilla install. Reopen if needed. Moved to 1.3 to get it out of 1.2.6 scope.

Note: See TracTickets for help on using tickets.