Skip to:
Content

Opened 9 years ago

Closed 8 years ago

#2605 closed enhancement (duplicate)

Toggle Activity Replies

Reported by: paulhastings0 Owned by:
Milestone: 1.5 Priority: major
Severity: Version:
Component: Activity Keywords: toggle, activity replies, bp-default
Cc: paulhastings0@…

Description

Sometimes the activity replies to an individual activity update can be overwhelming.

After clicking "Show all zz comments" there's no way to hide the comments again. So if a user accidentally clicks "Show all 39 comments" then there's no way for them to hide those 39 comments which forces them to scroll down past 39 comments that they don't care about... leading to a unpleasant user-experience.

I suggest there be a simple button called "Toggle activity Replies"... which does just that.

Change History (3)

#1 @paulhastings0
8 years ago

  • Keywords bp-default added
  • Priority changed from normal to major

@jjj @djpaul @boone I think that #2230, #2587, and this current ticket should all be combined.

The more and more that I think about it, the more I'm convinced that by default all of the activity stream replies should start completely collapsed. Users would only see the original activity update and then a button at the bottom that says "View all XYZ replies" (e.g. "View all 2 replies" or "View all 137 repies").

After clicking the the "View all XYZ replies" button the activity update will pull in all the replies via AJAX. At the end of the replies section there will be a button saying "Collapse all replies" that will collapse all the replies via jQuery.

Benefit 1. It drastically cleans up the main activity stream. Users will quickly browse the activity stream just by reading the original updates. While reading if they spot something they're interested they can easily drill down into the discussion.

Benefit 2. Shorter page height. No one likes to deal with scroll bars that are only millimeters high. Enough said.

Benefit 3. Faster site speed. We'll only be downloading 20 activity updates instead of 20 activity updates + 100s of activity replies.

#2 @paulhastings0
8 years ago

The patch that @jjj put on testbp.org a few weeks ago broke the site after 20 or so comments, has anyone else had any luck with controlling their activity stream?

#3 @boonebgorges
8 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2587

Note: See TracTickets for help on using tickets.