Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2573 closed defect (bug) (no action required)

A Bug about Blogs

Reported by: ri-kun Owned by:
Milestone: 1.5 Priority: critical
Severity: Version:
Component: Blogs Keywords: blogs, blog, network
Cc: ri-kun

Description

As you all know WP 3.0 can now create multisite. and to enable blogs in BP 1.2.5.2 you have to create a NETWORK. But there is a bug about the blogs. I believe its a bug since not only me is experiencing about this but all of new users I believe.

  1. The base install blog/default WP blog became a blogs in every member.
  2. The base install blog/default WP blog with unknown reason is added in the blogs directory (example.com/blogs)
  3. If you will add a new site tru WP Panel (super admin > admin > create a site) it is also added in the blogs directory (example.com/blogs)
  4. When a user creates a blog instead of example.com/blogs/user it become example.com/user

To fully understand this bug heres a screencap I took: http://i630.photobucket.com/albums/uu22/s2ne1/myblogsremove.png

Change History (3)

#1 @ri-kun
9 years ago

  • Cc ri-kun added
  • Component changed from Core to Blogs
  • Keywords blogs blog network added

#2 @boonebgorges
9 years ago

  • Resolution set to invalid
  • Status changed from new to closed

This all sounds like expected behavior.

If you've got more questions about how WordPress network blogs work with BuddyPress, pop into buddypress.org/support/topics.

#3 @r-a-y
9 years ago

Re: 1 - This doesn't sound correct to me. You should only have blogs that you have created listed there.

Re: 3 - The terminology in WP 3.0 changed so that blogs are now sites. But in BuddyPress, we didn't make this distinction because in BuddyPress' case, these new sites are user blogs.

All the rest sounds correct.

Note: See TracTickets for help on using tickets.