Skip to:
Content

Opened 4 years ago

Closed 3 years ago

#2559 closed enhancement (wontfix)

custom post_type posts are not displayed in the activity stream

Reported by: sdboer Owned by:
Milestone: 1.5 Priority: normal
Severity: Version:
Component: Activity Keywords:
Cc: sdboer

Description

custom post_type posts are not displayed in the activity stream

Change History (4)

comment:1 sdboer4 years ago

  • Cc sdboer added

comment:2 anointed4 years ago

imo probably should not include custom post-types by default. I have many scenario's where I use post-types to manage data that should never be displayed publicly.

Besides, it's easy enough to add them in manually, thus giving us greater control of what is displayed in the stream, and how it's displayed.

comment:3 DJPaul4 years ago

  • Milestone changed from 1.2.5 to 1.3
  • Type changed from defect to enhancement

Changing to enhancement as this is a new feature, not a bug report.
I wonder if we could make use of register_post_type() 'supports' argument to indicate display in the BuddyPress activity stream, perhaps.

comment:4 boonebgorges3 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

I'm not sure how we'd support this in core. In order to record activity items, you have to have a customized piece of text for the action, like "%s posted a new blog post %s". There's no real place for that in register_post_type().

When I build custom post types that I want to appear in the activity stream, I just build a little function that hooks to save_post and records a new activity item using something like bp_activity_add(). I don't think it's unreasonable to expect plugin authors to do this.

In other words, anointed +1 :)

Note: See TracTickets for help on using tickets.