Skip to:
Content

Opened 4 years ago

Closed 3 years ago

#2552 closed defect (bug) (duplicate)

BP needs to handle PATHINFO "almost pretty links"

Reported by: DJPaul Owned by:
Milestone: 1.5 Priority: major
Severity: Version:
Component: Core Keywords:
Cc:

Description

Tagging this 1.3 only because it could be large impact (or 1.2.7 if we have one of those).

RE: http://codex.wordpress.org/Using_Permalinks#PATHINFO:_.22Almost_Pretty.22

Servers which use PATHINFO (putting index.php at the front of the permalink settings in the WP Admin) won't work with BuddyPress because all of our links involve site_url(). Look at something like WP's the_permalink() to see how it utilises the custom permalink.

I have a URL for a demo site with this problem, though I'm not sure if I'm allowed to give the URL out publicly. The good news is that if you type in http://example.com/index.php/members/, everything works. The problem is all of the links in the theme, etc.

Change History (5)

comment:2 DJPaul3 years ago

This might be doable when the root_slug/slug fix is in (i.e. add a prefix on to root_slug).

comment:4 cnorris233 years ago

Something to keep in mind, this will be one of those "bonus features" we get when we make the switch to CPTs.

comment:5 DJPaul3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Good spot finding the related tickets; let's centralise everything on to #2299 as it has a patch.

Note: See TracTickets for help on using tickets.