Skip to:
Content

Opened 9 years ago

Closed 8 years ago

#2551 closed defect (bug) (no action required)

Forums are not being displayed properly

Reported by: ramnew2006 Owned by:
Milestone: 1.5 Priority: critical
Severity: Version:
Component: Forums Keywords: forums, forum tags
Cc:

Description

Hi.

I installed buddypress and then enabled bbpress through buddypress. I created groups with forums. and i created sufficient number of forums too.

we have all topics and my topics and forum tags on forums page
My problem is when i load the forums page every time its showing there were no topics found.I have to click on the tabs All topics manually again to get the topics loaded. and also forum tags on bottom are not being displayed.

i created a new user who did not create any topics in forums. now when i load the forums page through new user. its working properly and forum tags are getting displayed. after that i created a topic in a forum. now the problem again started. i am thinking the tab ” My Topics” on forums page is causing the problem.

please help me to solve this problem.

site address : http://www.way2ias.com/

Change History (4)

#1 follow-up: @ramnew2006
9 years ago

  • Priority changed from major to critical

#2 in reply to: ↑ 1 @ramnew2006
9 years ago

I found the bug. This is happening due to the presence of "My Topics" in forums page. Once i remove the code from forum index page in the template everything is fine. But only thing is i cannot see my forum topics now. so please use this info and solve this bug...

<?php if ( is_user_logged_in() && bp_get_forum_topic_count_for_user( bp_loggedin_user_id() ) ) : ?>
						<li id="forums-personal"><a href="<?php echo bp_loggedin_user_domain() . BP_GROUPS_SLUG . '/' ?>"><?php printf( __( 'My Topics (%s)', 'buddypress' ), bp_get_forum_topic_count_for_user( bp_loggedin_user_id() ) ) ?></a></li>
					<?php endif; ?>

#3 @ramnew2006
9 years ago

  • Milestone changed from 1.2.5 to 1.3

#4 @boonebgorges
8 years ago

  • Resolution set to invalid
  • Status changed from new to closed

I'm not able to reproduce the problem on a fresh installation of BuddyPress trunk or branch. The My Topics link works fine, and the forum topics load just fine with the My Topics link in place. I'm guessing it's a problem with a custom theme or plugin you're using.

If you're still having the problem, you might want to ask on the buddypress.org/support/topics forums, where there are lots of people who might be able to help with your particular situation. In particular, they'll want to know whether you're using a customized installation - whether your'e using a theme other than bp-default, and whether you're using any plugins other than BuddyPress.

If you're able to isolate the problem, and it is indeed a problem with BuddyPress core, please reopen this ticket with detail about what's causing the problem.

Note: See TracTickets for help on using tickets.