Skip to:
Content

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#2513 closed defect (bug) (fixed)

activity feed no longer showing commented on

Reported by: intimez Owned by:
Milestone: 1.2.7 Priority: major
Severity: Version:
Component: Core Keywords: activity, comment, missing, feed dev-feedback
Cc:

Description

activity feed it's broken

before it shows " testuser commented on the blog post my first post "
now it simply do not even show up in activity feed

[wordpress3+buddypress1.2.5.2]

Change History (22)

comment:1 cnorris234 years ago

  • Keywords dev-feedback added

I can reproduce this, but I'm tracking down the change to make sure it wasn't on purpose. Blog comments don't appear in the activity stream at all now.

comment:2 cnorris234 years ago

@intimez
You should check the privacy settings for the blog in the dashboard. It will be under Settings > Privacy. If you have the "I would like to block search engines, but allow normal visitors" setting checked, then this is likely the problem.

comment:3 intimez4 years ago

@cnorris23

Settings > Privacy

I would like my site to be visible to everyone, including search engines (like Google, Bing, Technorati) and archivers

comment:4 cnorris234 years ago

Alright then. I'll look into this more then. Are you using the default theme, a child theme, or a custom theme?

comment:5 johnjamesjacoby4 years ago

  • Priority changed from normal to major

Can't reproduce but if it's legit, it's major.

comment:6 johnjamesjacoby4 years ago

Confirmed this on testbp.org. Will review today.

comment:7 johnjamesjacoby4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [3153]) Fixes #2513 and code cleanup to bp_blogs_record_comment function

comment:8 intimez4 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Tested changeset_r3153.diff for file /buddypress/bp-blogs.php and not working

made comment and click on activity or username, nothing listed

other buddypress activity showing

[wordpress3.0.1+buddypress1.2.5.2]

comment:9 follow-up: DJPaul4 years ago

intimez, the patch may not work piecemeal by itself. This works fine for me on BP 1.2 branch and WP 3.0.1.

comment:11 in reply to: ↑ 9 intimez4 years ago

Replying to DJPaul:

intimez, the patch may not work piecemeal by itself. This works fine for me on BP 1.2 branch and WP 3.0.1.

@DJPaul

I apologize. I've tested past patch by itself and assumed this was same way. Just wanted to help. How can I test on wordpress3.0.1+buddypress1.2.5.2?

comment:12 intimez4 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Download bleeding as recommended by @johnjamesjacoby to help test

Tested new install of below and not working:
wordpress3.0.1+buddypress1.2.6-bleeding (branches_1.2-r3194)

Settings > Privacy > Site Visibility
I would like to block search engines, but allow normal visitors

Let me know if need to list other settings

comment:13 johnjamesjacoby4 years ago

If you are blocking search engines, then no blog activity will appear because the blog isn't considered public. For the activity stream to show blog posts and comments, you will want to set the Site Visibility to public.

comment:14 intimez4 years ago

@johnjamesjacoby

It was working in previous version so guess it's permanent fix/change. If setting set to non-public, all activity should not appear also, not just blog post comment. Kind of odd, no?

comment:15 johnjamesjacoby4 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

If it was 'working' then it was actually broken. :)

A blog is only 1 component of a BuddyPress site. If the blog is private, the group is private, or the forum is private, then those pieces of activity won't appear in the stream.

comment:16 intimez3 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Upgraded and the issue still there. Last time was working was pre 1.5 I think. I also notice same problem on testbp.org

comment:17 cnorris233 years ago

  • Milestone changed from 1.2.6 to 1.2.7

comment:18 johnjamesjacoby3 years ago

It happens on testbp.org because I set the blog back to private.

Can anyone confirm this is happening on an active single site install that is NOT set to private, as I can't duplicate it.

comment:19 intimez3 years ago

@johnjamesjacoby

I believe this happens on upgrades from 1.2.5

If you set testbp.org to approve comments and once approved, the comment will not appear.

I could be wrong but I don't think it was doing that on new installs.

comment:20 johnjamesjacoby3 years ago

I know they don't appear on testbp.org, because the blog is set to private.

If I make the blog public and approve a comment, it will appear. :)

I'll test this again today to verify though.

comment:21 johnjamesjacoby3 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [3416]) Fixes #2513 props intimez for being persistent

comment:22 johnjamesjacoby3 years ago

(In [3417]) Fixes #2513 (trunk ) props intimez for being persistent

Note: See TracTickets for help on using tickets.