Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2512 closed defect (bug) (duplicate)

change to duplicate email address allowed

Reported by: intimez's profile intimez Owned by:
Milestone: 1.2.6 Priority: normal
Severity: Version:
Component: Core Keywords: duplicate, registration, email, allowed
Cc:

Description

Duplicate email address is checked during registration but not during member account change.

Anyone else seeing same problem?

Register member #1 with email test@…
Register member #2 with email test@… (duplicate email not allowed)
Register member #2 with email test2@… then go to My Account - General - Settings to change to test@… (allowed)

[wordpress3+buddypress1.2.5.2]

Change History (7)

#1 @intimez
12 years ago

Delete original post above since it's not format correctly

Another try ...

Duplicate email address is checked during registration but not during member account change.

Anyone else seeing same problem?

Register member 1 with email test @ example.com
Register member 2 with email test @ example.com (duplicate email not allowed)
Register member 2 with email test2 @ example.com then go to My Account – General – Settings to change to test @ example.com (allowed)

[wordpress3+buddypress1.2.5.2]

#2 @nuprn1
12 years ago

semi-related to this patch where i added in the wordpress checks on the email (if email address is changed)
http://trac.buddypress.org/ticket/2517

#4 @r-a-y
12 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

I'd say this isn't just related, it's a duplicate of #2277.

#5 @r-a-y
12 years ago

I meant duplicate of #2517.
Sorry!

#6 @intimez
12 years ago

@r-a-y

I think it other way around. #2517 is duplicate of #2512 by number order.

haha

:-)

#7 @r-a-y
12 years ago

@intimez -
I give priority to the ticket with a patch ;)

Note: See TracTickets for help on using tickets.