Skip to:
Content

BuddyPress.org

Opened 14 years ago

Closed 13 years ago

#2496 closed defect (bug) (no action required)

What if members name is same as post title/slug

Reported by: nahummadrid's profile nahummadrid Owned by:
Milestone: 1.5 Priority: trivial
Severity: Version:
Component: Core Keywords:
Cc:

Description

I'm on wp3.0 and 1.2.4.1 BP ---
While working on a custom header nav menu for blog posts versus rest of the site (brief version below. ) I noticed on a couple of my members profiles had the custom menu appear in their profile. I dug deeper and noticed that the user name was the same as a blog post title that existed. i made the blog post title slightly different and it removed the custom nav menu from the users.

from my original post in bp.org http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/if-members-name-is-same-as-post-titleslug/

<?php if ( is_current_blog(1) && is_single() ) : ?>
<ul>
<li>menu for blog posts</li>
</ul>
<?php else:?>
<ul>
<li>menu for everything else</li>
</ul>
<?php endif;?>

Change History (3)

#1 @johnjamesjacoby
14 years ago

  • Milestone changed from 1.2.6 to 1.3

Sadly there isn't this kind of slug detection built into either WP or BP.

Bumping to 1.3 to look at a better solution later.

#2 @boonebgorges
14 years ago

This is basically a duplicate of #2123, right?

#3 @DJPaul
13 years ago

  • Resolution set to invalid
  • Status changed from new to closed

I can't recreate this on trunk. Quite possibly it's been resolved as a consequence of some of the page changes in 1.3.

Also, if you are building a BuddyPress theme and you want to be sure that you're targeting a page or post, and not anything from BuddyPress, you can use the bp_is_blog_page() template tag.

Note: See TracTickets for help on using tickets.