Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

#2487 closed defect (bug) (wontfix)

Activation Issue with BP 1.2.5 and WordPress 2.9.2

Reported by: jeffsayre Owned by:
Milestone: 1.2.6 Priority: normal
Severity: Version:
Component: Core Keywords: Activation, site wide
Cc:

Description

BuddyPress 1.2.5 has an activation issue under WordPress 2.9.2. When a Site Admin goes to activate BuddyPress in the plugins menu, clicking the "Activation" link should enable BuddyPress site wide as there is a “Site Wide Only: true” header tag in bp-loader.php. However, it does not activate site wide.

You can get BuddyPress to activate site wide be clicking the “Activate BuddyPress Site Wide” link — which should not be necessary. This issue is only seen in WordPress 2.9.2. BuddyPress activates as it should in WordPress 3.0.

If a fix cannot be found, the “Requires at least” tag in BP’s readme.txt file should be changed to WP 3.0. Otherwise, we will have people activating BP for a single blog, and not site wide, which will cause problems and unnecessary support postings in the forums.

I'm still investigating to see what changed between 1.2.5 branch test versions and the final 1.2.5 tagged version that might be causing this issue.

This issue has been independently verified by three people. See this BuddyPress Support thread for more details: http://buddypress.org/community/groups/requests-feedback/forum/topic/need-testers-activation-issue-with-bp-v-1-2-5/

Change History (2)

#1 @cnorris23
11 years ago

@jeffsayre
As long as I'm understanding the issue correctly, this is resolved now, correct? Now that BP 1.2.5.2+ requires WP 3.0 that is.

#2 @johnjamesjacoby
11 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

Correct. Since requires tag was bumped, this is no longer an issue.

Note: See TracTickets for help on using tickets.