Skip to:
Content

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2475 closed defect (bug) (fixed)

jQuery alt class insert - looks at tr for an entire page instead of per table

Reported by: nuprn1 Owned by:
Milestone: 1.2.5 Priority: major
Severity: Version:
Component: Core Keywords:
Cc:

Description

If inserting another table above (or even below) - lets say the forums component recent discussion (but anything using forums-loop or other means)

The jQuery code used to insert the alt class (along with the php filter used to insert the alt class too) will cause all rows to be highlighted depending on the table above (or below)

See attached screenshots

Attachments (2)

zebraisahorse.gif (31.7 KB) - added by nuprn1 4 years ago.
All rows highlighted with alt class
horseturnsintozebra.gif (27.2 KB) - added by nuprn1 4 years ago.
Adding one more row to a table above it - corrects the alt class on tables below it

Download all attachments as: .zip

Change History (5)

nuprn14 years ago

All rows highlighted with alt class

nuprn14 years ago

Adding one more row to a table above it - corrects the alt class on tables below it

comment:1 nuprn14 years ago

I don't have a patch (not a jquery pro) - but I guess the jQuery code should look at each table->tr on a page instead of all tr's on a page.

comment:2 johnjamesjacoby4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2465. Thanks for the extra information and screen shots; helped to formulate a fix.

comment:3 johnjamesjacoby4 years ago

  • Resolution changed from duplicate to fixed

(In [3111]) Fixes #2465 and #2475, for real this time.

Note: See TracTickets for help on using tickets.