Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 11 years ago

#2471 closed defect (bug) (no action required)

Notifications: "accepted your friendship request" not disappearing

Reported by: erich73's profile erich73 Owned by:
Milestone: 1.5 Priority: minor
Severity: Version:
Component: Core Keywords:
Cc:

Description

A user accepted my friendship request, which shows within "Notifications" at the BuddyBar.

I have clicked on this Notification, but it does NOT DISAPPEAR.
It still says "UserXYZ" accepted your friendship request.

Using BP 1.2.4.1

Can you please fix this JJJ ?

Change History (4)

#1 @johnjamesjacoby
12 years ago

  • Milestone changed from 1.2.5 to 1.3

Hi erich73. I'm afraid I cannot duplicate this issue on any of my installs so I'm going to bump it to 1.3.

The notifications system needs a rework for 1.3 anyhow, since it's always been 1 page load behind what people's natural reaction is to how notifications work.

If you can find a more specific cause to this problem, or take a screen cast of how you're able to duplicate it (try using Jing) I'll be happy to look into it further.

#2 @erich73
12 years ago

it is just the normal process:
Myself as Admin have invited a user to become a friend.
The user accepted the friendship-request.

I do see this in the Nitification-tab at the BuddyBar.
I have checked again and the message does not disappear at all when being clicked.

#3 @boonebgorges
12 years ago

  • Priority changed from normal to minor

I've seen this as well on certain installations but I don't have steps to reproduce it. I wonder if it has something to do with how friend request notifications are cleared (with a url arg http://trac.buddypress.org/browser/trunk/bp-friends.php#L103). Maybe that isn't working right on some setups (getting hijacked by a plugin or something like that).

If no one can offer an explanation, this will likely get booted past 1.3

#4 @DJPaul
11 years ago

  • Resolution set to invalid
  • Status changed from new to closed

I can't recreate this on trunk. Please re-open the ticket if you can, and provide step-by-step instructions. Thanks!

Note: See TracTickets for help on using tickets.