Skip to:
Content

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#2451 closed defect (bug) (fixed)

BP_ENABLE_MULTIBLOG Avatars Missing

Reported by: windhamdavid Owned by:
Milestone: 1.5 Priority: normal
Severity: Version:
Component: Core Keywords:
Cc: PeterAnselmo

Description

with BP_ENABLE_MULTIBLOG set, subdomain and subdirectory avatars go missing.
replicated with localhost and remote ~ 1.2.4.1 with 2.9.2 and 3.0
http://gzet.net/people
http://dev.gzet.net/people

Change History (6)

comment:1 johnjamesjacoby4 years ago

Can you try the 1.2 branch and report back?

comment:2 windhamdavid4 years ago

the 1.2 branch is working fine and I noted the upcoming merge ~ http://trac.buddypress.org/ticket/2469

comment:3 windhamdavid4 years ago

I diff'd the branch and 1.2.5 tag and didn't see any difference in the way bp_core_avatar_url is being handled. I'm not sure of what is merging from the 1.2 branch and trunk or the best way to patch this, but $upload_dirbaseurl? doesn't seem to respond and this simple filter works for 1.2.5 and 3.0 avatars in multiblog mode - http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/custom-avatars-arent-shown-on-single-blogs-in-wpmu/?topic_page=2&num=15#post-59329

comment:4 PeterAnselmo4 years ago

  • Cc PeterAnselmo added

I can confirm this.

The problem is in bp_core_avatar_upload_path() and bp_core_avatar_url().

if you're using a sub blog, it returns "wp-content/blogs.dir/1/files"
if you're using the main blog, it returns "wp-content/uploads"

comment:5 djpaul3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [3851]) Fix URL to uploaded avatars on non-BP_ROOT_BLOG sites. Fixes #2451, #2574 and #2968. (branch)

comment:6 djpaul3 years ago

(In [3852]) Fix URL to uploaded avatars on non-BP_ROOT_BLOG sites. Fixes #2451, #2574 and #2968. (trunk)

Note: See TracTickets for help on using tickets.