Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#2450 closed defect (bug) (worksforme)

BP_ENABLE_ROOT_PROFILES not working properly on WP 3.0

Reported by: r-a-y Owned by:
Milestone: 1.5 Priority: normal
Severity: Version:
Component: Core Keywords:
Cc:

Change History (5)

#1 @windhamdavid
9 years ago

i have member profiles running root on several 3.0 installs without any problems.

I think there are other issues regarding the $page $tax rewrites. I had errors that started popping up in one of the last updates http://core.trac.wordpress.org/changeset/15269 - the one that borked the body_class() and it's subsequent revisions.

It was feeding me 404's on some root/%permalinks%/ including root_profiles, posts, and cat/tax. I've tried to duplicate the errors with the rewrites exactly so that i can report in on the wp-trac, but I've yet to put my finger on it and through a series of removing rewrites via plugins or functions, I've now fixed it and and these are my only errors in my log.

~ Object of class WP_Error could not be converted to string in/wp-includes/formatting.php on line 433
~ Object of class WP_Error could not be converted to string in /wp-includes/formatting.php on line 2829
~ Object of class stdClass could not be converted to string /wp-includes/post-template.php on line 432

http://core.trac.wordpress.org/ticket/13957
~ this is the ticket i suspect

#2 @johnjamesjacoby
9 years ago

  • Milestone changed from 1.3 to 1.2.5

#3 @johnjamesjacoby
9 years ago

  • Milestone changed from 1.2.5 to 1.3

I have them running on root also on at least three installations with no issues.

If there are other plugins that deal with permalinks that are flushing the rewrite rules (post types, taxonomies, pagination, etc) then they may be conflicting with a recent change in WP core.

Punting to 1.3 since this doesn't appear to be a BP issue, but probably warrants a closer look later.

#4 @DJPaul
8 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

This seems to work fine on WP 3.1.1 and BP r4196 so I'm closing the ticket.

#5 @boonebgorges
8 years ago

It was fixed in r4110.

Note: See TracTickets for help on using tickets.