Skip to:
Content

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#2419 closed enhancement (fixed)

Autocomplete should populate results based on all members you can message (i.e. everyone) not just "Friends".

Reported by: Takeo Owned by:
Milestone: 1.5 Priority: normal
Severity: Version:
Component: Core Keywords: autocomplete, needs-review
Cc:

Description

With the “Friends” component disabled, autocomplete on the "Send To" field in "Messages > Compose" should work for all members. Otherwise there's no way to choose a recipient. You can write a message but you can't send it. The only way to send a message is to visit the recipient's profile and click "Send Private Message". If you can message anyone by visiting their profile, why not be able to message anyone by visiting "Messages > Compose"? With "Friends" turned on, autocomplete could go back to using just friends. But with "Friends" turned off, autocomplete should work for all members.

Change History (14)

comment:1 r-a-y4 years ago

Have you tried manually typing in the username in the "Send to" input field?
It should work w/o needing the autocomplete functionality.

comment:2 Takeo4 years ago

Thanks r-a-y!

I assumed it was not working since autocomplete didn't pop up. It only pops up for friends. Just tested and you're right. You can still send to anyone, you just don't get the autocomplete.

I still feel the lack of feedback / help is a usability issue. Since you're allowed to message any user, it seems logical that autocomplete should work for any user. Seems unreasonable for people to have to recall usernames (and type them without error).

I understand this could be an issue with a large user base. Maybe when "Friends" is turned off, the system should treat everyone as a "Friend" rather than treating everyone as a non-Friend???

comment:3 r-a-y4 years ago

  • Summary changed from "Compose" becomes unusable with friends disabled. to Autocomplete doesn't work when friends component is disabled
  • Type changed from defect to enhancement

I've changed the title of this ticket to better reflect the issue and the ticket type to an enhancement, since this appears to be the intended behavior.

See the comments listed in the code:

/* AJAX autocomplete your friends names on the compose screen */
function bp_dtheme_ajax_messages_autocomplete_results() {
...

comment:4 davelewis@…4 years ago

Agree with the ticket changes. Thanks Ray.

comment:5 erich734 years ago

does this mean when using the "BP Followers Plugin", the auto-complete is not working anymore ?

comment:6 davelewis@…4 years ago

The issue is autocomplete not populating the autocomplete results with ALL members of the website. Which makes little sense since you can message them by typing their username. If they are message-able... they should show up in the autocomplete list.

The Followers plugin is not relevant to the issue. I don't know if autocomplete works for people you are following. Haven't tried it. Again, the issue is auto-complete not working for everyone that you have the capability of messaging (i.e... everyone)

comment:7 davelewis@…4 years ago

  • Summary changed from Autocomplete doesn't work when friends component is disabled to Autocomplete should populate results based on all member you can message (i.e. everyone) not just "Friends".

comment:8 davelewis@…4 years ago

  • Summary changed from Autocomplete should populate results based on all member you can message (i.e. everyone) not just "Friends". to Autocomplete should populate results based on all members you can message (i.e. everyone) not just "Friends".

comment:9 r-a-y4 years ago

  • Keywords needs-review added

David, did you see my forum topic?
http://is.gd/cXT38

The code snippet listed there should do what you want.

I would set this as invalid and plugin territory, but a core dev should give their feedback.

comment:10 johnjamesjacoby4 years ago

  • Milestone changed from 1.2.5 to 1.3

I like the idea of this being a core option eventually. Bumping to 1.3 to give this a better look-see.

In the mean time, r-a-y you should make a real plugin out of this. I imagine there's probably an audience for it, and it will help work out any kinks until we integrate it into core.

comment:11 boonebgorges3 years ago

I'm just finishing a patch that gives admins an option to include all members in autocomplete. I have decided *not* to have it set to true automatically when the friends component is disabled, because it seems to me to be a spam facilitator. Friends component or no, admins have to define the BP_MESSAGES_AUTOCOMPLETE_ALL constant to flip the feature on.

comment:12 boonebgorges3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [3364]) Allows admins to allow message Componse To: autocomplete to include all members of the site. Fixes #2419, props r-a-y for the initial patch

comment:13 johnjamesjacoby3 years ago

Concerned about this scaling when there are hundreds of thousands of users. We will want to try this on testbp.org to see how it does with the few thousand there, but I have a feeling possibly not so good.

comment:14 boonebgorges3 years ago

I agree about the general scaling concern, but two points:

1) It uses the built-in BP_Core_User::search_users(), so is as scalable as that function is. (Maybe still not very, I suppose.)
2) It's off by default.

Does that mitigate things?

Note: See TracTickets for help on using tickets.