Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

#2405 closed defect (bug) (fixed)

incorrect status time? sometime ago?

Reported by: intimez Owned by:
Milestone: 1.2.5 Priority: normal
Severity: Version:
Component: Core Keywords: status, post, time, sometime, update, reply
Cc:

Description

admin posted an update: 1 hour, 50 minutes ago
user1 · sometime ago · Reply · Delete
admin · 0 seconds ago · Reply · Delete

If the posted update shows the time, shouldn’t all post update/reply below that line also show the time instead of sometime ago? Bug?

Attachments (1)

2405.001.diff (2.1 KB) - added by cnorris23 11 years ago.

Download all attachments as: .zip

Change History (9)

#1 @cnorris23
11 years ago

I can only reproduce this on the 1.2.x branch of BP. Current trunk doesn't have this issue. Since current trunk will be 1.3, and 1.2.4 will almost certainly be the last 1.2.x branch release, I'd say this is already fixed.

#2 @johnjamesjacoby
11 years ago

  • Milestone changed from 1.3 to 1.2.5

#3 @cnorris23
11 years ago

Following patch fixes your issue in my testing. It also fixes issue with the name now being stripslashed.

@intimez
Can you give it a test?

@cnorris23
11 years ago

#4 @intimez
11 years ago

@cnorris23
I haven't encountered the 'sometime ago' message after making the modification. It seems to account for the time down to seconds.

#5 @johnjamesjacoby
11 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [3062]) Fixes #2405 props cnorris23

#6 @nuprn1
11 years ago

  • Milestone changed from 1.2.5 to 1.2.6
  • Resolution fixed deleted
  • Status changed from closed to reopened

confirmed – i have the same issue now (7 hours ago)

messages_new_message uses ‘date_sent’ => time() instead of gmdate and since the templatetag uses bp_core_time_since - i assume this is throwing off the date

actually a few other oddities where notices use time() as well. (but that actually calls bp_format_time() in the templatetag)

#7 @nuprn1
11 years ago

  • Milestone changed from 1.2.6 to 1.2.5

ah dang it - wrong ticket - someone linked in "teh" wrong one for messages. ignore.

#8 @nuprn1
11 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.