Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2401 closed defect (bug) (fixed)

Activity stream: Tweak activity action for blog comments

Reported by: hotforwords's profile hotforwords Owned by: johnjamesjacoby's profile johnjamesjacoby
Milestone: 1.2.6 Priority: normal
Severity: Version:
Component: Blogs Keywords: has-patch
Cc:

Description

In the activity stream of Buddypress when connected to Wordpress, the wording is as such:

Someusername commented on the blog post Blog Post Name 4 minutes ago · View · Delete

The clickable name of the Blog Post Name should take you to the blog post, currently it takes you to the comment, which is what the View link does, thus creating redundancy.

It's an easy fix:

On line 428 of bp-blogs.php change:

$activity_action = sprintf( __( '%s commented on the blog post %s', 'buddypress' ), bp_core_get_userlink( $user_id ), '<a href="' . $comment_link . '">' . $comment->post->post_title . '</a>' );

to

$activity_action = sprintf( __( '%s commented on the blog post %s', 'buddypress' ), bp_core_get_userlink( $user_id ), '<a href="' . get_permalink( $comment->comment_post_ID ) . '">' . $comment->post->post_title . '</a>' );

Attachments (1)

2401.001.patch (904 bytes) - added by r-a-y 12 years ago.
Patch based on hotforwords

Download all attachments as: .zip

Change History (8)

#1 @johnjamesjacoby
12 years ago

  • Owner set to johnjamesjacoby
  • Status changed from new to assigned

Confirmed. Meant to fix this for 1.2.4 but missed it.

#2 @r-a-y
12 years ago

  • Milestone changed from 1.3 to 1.2.6

Let's move this up!

@r-a-y
12 years ago

Patch based on hotforwords

#3 @r-a-y
12 years ago

  • Component changed from Core to Blogs
  • Keywords has-patch added; activity stream links removed
  • Summary changed from Clean up the functionality of links in the activity stream to Activity stream: Tweak activity action for blog comments

#4 @johnjamesjacoby
12 years ago

I would rather us come up with a new phrase to include both links, than only include a link to the blog post. This is tricky because comments don't have titles.

I say this because I think when you read the activity, if you click the link then your intent is more than likely to read the comment, not the blog. But... We shouldn't assume anything either.

I was going to try to stuff this into 1.2.5, but I think it needs more thought.

#5 @r-a-y
12 years ago

If you're reading from the activity stream, the blog comment is already in the recorded activity content!

I guess we could move it to BP 1.3. Could use feedback from the community.

#6 @johnjamesjacoby
12 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [3116]) Fixes #2401 props hotforwords and r-a-y

#7 @johnjamesjacoby
12 years ago

Ran into this today on a client site, and I think this makes perfect sense.

The activity action will stay the same, since you want to "view" the comment in real time, but the link to the actual blog post should link you to the blog, not the comment.

Fixed. Thanks everyone!

Note: See TracTickets for help on using tickets.