Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2400 closed defect (bug) (duplicate)

Wrong Avatar and Gravatar after BP update

Reported by: Ipstenu Owned by:
Milestone: 1.2.5 Priority: critical
Severity: Version:
Component: Extended Profile Keywords: dev-feedback
Cc:

Description

This post details the saga, but basically since 1.2.3, all gravatars default to the AUTHOR avatar. Which is bad :)

http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/wrong-avatar-and-gravatar-after-bp-update/

Solution #2 is the best one IMO

Attachments (2)

fix-avatars.patch (2.5 KB) - added by johnjamesjacoby 10 years ago.
First pass at fixing broken avatars
Screen shot 2010-05-30 at 30 May - 10.31.00 AM.png (56.9 KB) - added by Ipstenu 10 years ago.
Wrong gravatars in blog comments

Download all attachments as: .zip

Change History (10)

#1 @DJPaul
10 years ago

  • Keywords dev-feedback added
  • Priority changed from normal to critical

#2 @DJPaul
10 years ago

  • Component changed from Core to XProfile

#3 @johnjamesjacoby
10 years ago

  • Milestone changed from 1.3 to 1.2.5

@johnjamesjacoby
10 years ago

First pass at fixing broken avatars

#4 @johnjamesjacoby
10 years ago

Please test this fix possibly for 1.2.4.2.

This has fixed avatar issues for me on single and multisite installs, in both subdirectory and subdomain installations.

The problem was the method used to check the existence of avatar files was never upgraded, even though the surrounding code was.

#5 @Ipstenu
10 years ago

On WP 3.0 it does not fix the problem where blog comments show the avatar of the post author and NOT the commentor.

@Ipstenu
10 years ago

Wrong gravatars in blog comments

#6 @rvenable
10 years ago

This sounds really similar to bug #2288 (currently set for milestone 1.3), which describes how BP "breaks some themes that pass a user email address to get_avatar() for comments, causing the comments to display the avatar for the blog post author rather than the comment author."

I attached a patch for that bug. I don't know if it will fix this one as well.

#7 @johnjamesjacoby
10 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Like rvenable said, this is a duplicate of #2288.

#8 @ipstenu
10 years ago

Confirming this is fixed after 1.2.5 update. :) Cheers!

Note: See TracTickets for help on using tickets.