Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 11 years ago

#2399 closed defect (bug) (no action required)

Group-name is adding strange code

Reported by: erich73's profile erich73 Owned by:
Milestone: 1.5 Priority: normal
Severity: Version:
Component: Core Keywords:
Cc: stas@…

Description

when creating a new Group, sometimes there is a strange numbering automatically being added to the Group-URL.

Like I have created a Group with Group-name "vankis.at".
Then the URL for that Group and also for the Blog is looking like this:

http://domain.com/groups/vankis-at-689611498/

Not sure why the number 689611498 is added to the URL, as the Group-name is unique on my website and no other Group with the same name or similar name is already exising.

I do not like this number being added to the Group-URL and also to the Group-Blog.

Strange thing is that this is not always happening. Just experienced this on that certain group I created.

running BP 1.2.3 and latest WPMU.

Change History (3)

#1 @sushkov
12 years ago

  • Cc stas@… added

It's not a bug, it's how BP handles duplicate/repeating slugs.
http://trac.buddypress.org/browser/trunk/bp-groups.php#L1534

All of your slugs are getting a random number appended?

#2 @r-a-y
12 years ago

  • Keywords reporter-feedback added

#3 @r-a-y
11 years ago

  • Keywords reporter-feedback removed
  • Resolution set to invalid
  • Status changed from new to closed

sushkov is correct.

If you already have an existing group with the same name, a random number will be appended to the slug to differentiate it from the original.

If all your group slugs have a random number suffixed, please reopen this ticket.

Note: See TracTickets for help on using tickets.