Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

#2398 closed defect (bug) (worksforme)

Lost all blogs

Reported by: stiddy Owned by:
Milestone: 1.2.5 Priority: major
Severity: Version:
Component: Blogs Keywords:
Cc:

Description

I just upgraded to the new version. I can see the blogs in my admin, but cannot access them.

error:
Fatal error: Call to undefined function wp_get_current_user() in /home/stidsti9/public_html/homechurchresource.com/hcc/wp-includes/capabilities.php on line 969

Help.

Change History (6)

#1 @DJPaul
10 years ago

wp_get_current_user() is in includes/pluggable.php which is loaded very near the beginning of your WordPress install chain. If you're getting this message something fairly fundamental has broken. It's probably best if you open a thread on the BuddyPress forums http://buddypress.org/support/topics/ with full details of your install, or/and to restore your blog/DB to its previous version and try the upgrade again.

#2 @apeatling
10 years ago

  • Milestone changed from 1.2.4 to 1.3

#3 @r-a-y
10 years ago

Related:
http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/upgraded-to-1-2-4-and-now-no-blogs-showing/

The wp_bp_user_blogs table gets wiped out after upgrading to BP 1.2.4.

The problem is with the $current_site->id addition in:
http://trac.buddypress.org/changeset/2992/branches/1.2/bp-blogs.php

#4 @r-a-y
10 years ago

  • Component changed from Core to Blogs
  • Priority changed from normal to major

#5 @johnjamesjacoby
10 years ago

  • Milestone changed from 1.3 to 1.2.5

Should be fixed in 1.2.4.1, but I'm bumping this to 1.2.5 to give this a better look asap.

#6 @johnjamesjacoby
10 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce this on 1.2.4.1. 1.2.4.1 was released specifically to address this issue, and it looks to have done so.

Note: See TracTickets for help on using tickets.