Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#232 closed defect (bug) (fixed)

Group Members Pagination Broken

Reported by: gogoplata Owned by:
Milestone: Priority: minor
Severity: Version:
Component: Keywords:
Cc: kriskarkoski@…

Description

On the Group Members page the pagination does not work. The first page correctly displays five group members but clicking on "2" or ">>" results in the error "This group has no members."

Change History (8)

#1 @gogoplata
13 years ago

  • Cc kriskarkoski@… added

#2 @apeatling
13 years ago

Not seeing this, is there an example group to look at?

#3 @apeatling
13 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

#4 @gogoplata
13 years ago

  • Priority changed from major to minor
  • Resolution worksforme deleted
  • Status changed from closed to reopened

Here's an example group:

http://mmafrenzy.com/groups/fantasy-ufc/members

Running r739.

#5 @apeatling
13 years ago

  • Milestone set to Groups 1.0

#6 @mnorland
13 years ago

The problem is the ajax call assumes 10 members shown per page, but the non-javascript links (and every other part of the system, e.g. pagination) is assuming 5.

To fix the ajax calls (will reduce the members shown per page to 5)
---
Line 148 of bo-groups/js/general.js
[part of jQuery("div#member-pagination a").livequery('click', ]

'num': 10

---
To make the other calls display 10 per page, start here:
Line 1358 of bp-groups/bp-groups-templatetags.php:
[ part of bp_group_member_pagination_count() ]

$to_num = ( $from_num + 4 > $members_template->total_member_count ) ? $members_template->total_member_count : $from_num + 4;

---
I don't actually have a BP site to play with, I was just tracking this down for a friend, or I'd make the full edits for solution 2. The quickest fix is obviously to just make the ajax calls be 5 rather than 10.

#7 @apeatling
13 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in r921. Changed both to 10 users per page.

#8 @(none)
12 years ago

  • Milestone Groups 1.0 deleted

Milestone Groups 1.0 deleted

Note: See TracTickets for help on using tickets.