Skip to:
Content

BuddyPress.org

Opened 14 years ago

Closed 14 years ago

#2284 closed defect (bug) (duplicate)

Duplicate instances of the same user are added to Groups

Reported by: markschafer's profile markschafer Owned by:
Milestone: 1.5 Priority: normal
Severity: Version:
Component: Groups Keywords: group members, duplicate
Cc:

Description

Multiple instances of the same members are being added to a Group when the following circumstances exist:

  1. multiple group admins received and accepted requests resulting in 2 instances of the same members in the group.
  2. a join group request is made when an invite is outstanding to the same user and the request is accepted and the invite is also accepted.

Need a test to deny the creation of a second instance of the same member in a group. No way to remove the extra instance of the same member (without deleting both and then adding the member again or through the DB).

More Info:
http://buddypress.org/forums/topic/group-membership-double-membership-bug

Change History (3)

#1 @markschafer
14 years ago

  • Component changed from Core to Groups

#2 @3sixty
14 years ago

This is the "double membership bug" also reported in Forums 4 weeks ago:

http://buddypress.org/forums/topic/group-membership-double-membership-bug

#3 @DJPaul
14 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2222

Note: See TracTickets for help on using tickets.