Skip to:
Content

Opened 4 years ago

Closed 4 years ago

#2264 closed defect (bug) (fixed)

Group Forums: Edit Details: forum_desc not updating in bbpress forum table

Reported by: nuprn1 Owned by:
Milestone: 1.2.6 Priority: major
Severity: Version:
Component: Forums Keywords: has-patch
Cc:

Description

Create a new group forum and forum_desc is inserted into the bbPress forum tables.

Edit the group detail description and nothing is updated on the bbPress side.

Expected behavior is to update both set of tables.

Attachments (1)

2264.001.diff (887 bytes) - added by cnorris23 4 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 3sixty4 years ago

This issue goes beyond forum_desc - when you change a group name, there is no change in the forum_slug or forum_name in wp_bb_forums.

comment:2 erich734 years ago

  • Milestone changed from 1.3 to 1.2.5

Hi JJJ,

could you please fix this issue in BP 1.2.5 as I am using the Plugin "BP Forums Extras" and this bug seems to be limiting the full use of that plugin.

http://buddypress.org/community/groups/buddypress-group-forum-extras/

Many thanks,

comment:3 cnorris234 years ago

  • Keywords has-patch added

I've attached a rough patch. By default the slug is not updated, as it's not updated in the groups table either. Automatically changing the slug whenever you edit group details is bad for SEO, and for bookmarks. However, I did add a filter to allow you to edit the slug.

@nuprn1, @3sixty, @erich73
If this you need soon, the action hook 'groups_details_updated' would easily allow you to update everything you need.

cnorris234 years ago

comment:4 johnjamesjacoby4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [3082]) Fixes #2264

comment:5 nuprn14 years ago

  • Milestone changed from 1.2.5 to 1.2.6
  • Resolution fixed deleted
  • Status changed from closed to reopened

re-opening as the bug still exists in wp3.0/bp1.2.5.2

updated the group settings via normal buddypress means
verified wp_bb_forums in phpmyadmin the forum row information not syncing

comment:6 johnjamesjacoby4 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [3175]) Fixes #2264

Note: See TracTickets for help on using tickets.