Skip to:
Content

Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#2256 closed defect (bug) (no action required)

Problem BuddyPress Backwards Compatibilty 0.6

Reported by: j.conti Owned by: apeatling
Milestone: Priority: major
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

Hi,

Many plugins donnot work correctly with BuddyPress Backwards Compatibilty 0.6.

All these problems do not happen with theme BuddyPress Default 1.2.3

  • oEmbed for BuddyPress donnot work see atachment, only show the link
  • bp-album+ Add another user menu (BP 1.2.3 user menu) see atachment
  • bp-galery, the same, add another user menu, see atachment

Mabe, BuddyPress Backwards Compatibilty 0.6. has to deactivate the bp 1.2.3 menu.

Does the problem be on BP 1.2.x, BuddyPress Backwards Compatibilty 0.6 or the plugins?

Thak you

Attachments (3)

videos.JPG (50.9 KB) - added by j.conti 9 years ago.
oEmbed for BuddyPress donnot work
album+.JPG (85.6 KB) - added by j.conti 9 years ago.
Album+ add BP 1.2.3 user menu
bp-gallery.JPG (94.4 KB) - added by j.conti 9 years ago.
bp-galley, add bp 1.2.3 user menu

Download all attachments as: .zip

Change History (16)

@j.conti
9 years ago

oEmbed for BuddyPress donnot work

@j.conti
9 years ago

Album+ add BP 1.2.3 user menu

@j.conti
9 years ago

bp-galley, add bp 1.2.3 user menu

#1 @cnorris23
9 years ago

  • Resolution set to invalid
  • Status changed from new to closed

This is likely a problem with the plugins. I would contact them, or see about a fix. It's also possible that some of the changes that have happened between 1.2 and 1.2.3 have caused the plugins to break. Closing as invalid, but if, after talking to the plugin authors, it's decided that BP is the problem, the feel free to reopen.

#2 @j.conti
9 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

#3 @j.conti
9 years ago

I'm sorry,

This happens with BP 1.2.2.1 with BP child theme 1.1 with backwards compatibility plugin.

On profiles, there are two users menus

#4 follow-up: @j.conti
9 years ago

I tested with all 1.2 version,

allways the same, two menus.

I think, the problem is on backwards compatibility

#5 @j.conti
9 years ago

  • Owner set to apeatling
  • Status changed from reopened to assigned

#6 in reply to: ↑ 4 @_DorsVenabili
9 years ago

Hi j.conti, I think it is a problem of the child theme, you only need to change some things in the CSS would appear properly :)

#7 @j.conti
9 years ago

Ok,

I fixed the problem adding this lines to css:

#item-nav, #subnav {
display: none;
}

The problem was that BP 1.2.X force its own menu even you are using a BP 1.1 Theme.

Andy, I think you should implement this css on BuddyPress Backwards Compatibilty for menus are not duplicated.

Thank's folks

#8 @cnorris23
9 years ago

  • Keywords needs-patch added; Backwards Compatibilty removed
  • Milestone changed from 1.2.4 to Future Release
  • Summary changed from Problem with WPMU 2.9.2 + BP 1.2.3 + BuddyPress Backwards Compatibilty 0.6 to Problem BuddyPress Backwards Compatibilty 0.6

@j.conti

The CSS fix you've outlined is merely a bandage on the underlying problem. While this fix may work for you, it has a high likelihood causing conflicts for others. As this the BP trac, and not the BP Compatability Plugin trac, I would not expect a quick fix.

#9 @DJPaul
9 years ago

  • Resolution set to invalid
  • Status changed from assigned to closed

If a plugin isn't working with BuddyPress -- regardless of version -- report it to that plugin's author.

#10 @j.conti
9 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

The Author is Andy (apeatling)

Is there another trac for this plugin?

#11 @cnorris23
9 years ago

  • Keywords needs-patch removed

Is there another trac for this plugin?

It's the same as the WP plugins trac. (BuddyPress Backwards Compatibility - http://plugins.trac.wordpress.org/browser/buddypress-backwards-compatibility). However, as DJPaul already stated, this is an issue for the individual plugin authors. The backwards compatibility plugin's sole job is to make sure that the old, deprecated functions from versions past are available to themes (and in a lesser, last resort, sense, plugins). It's meant to be a bridge until you can update your theme to function properly with the current version of BP and it's new functions.

Does the problem be on BP 1.2.x, BuddyPress Backwards Compatibilty 0.6 or the plugins?

This question has been answered twice already. The answer is still that it's not BP or the BP Backwards Compatability Plugin. However, it's not the plugins authors problem either. The problem is with your theme. The plugin authors have updated their plugins to be only compatible with at least BP 1.2+. This means that they no longer use functions that have been removed and placed in the BP Compatibility plugin. They use functions from 1.2+ only. However, you're theme still uses the old functions. The result: plugins can't work with your theme because you don't have the necessary functions in your theme.

The issue with duplicate user menus, is likely to be a bug in BP compat, but that's still not a BP issue, and still doesn't belong on the BP trac. You could bring it up in the forums or you can file a ticket with the BP compat trac.

#12 @fanquake
7 years ago

  • Resolution set to invalid
  • Severity set to normal
  • Status changed from reopened to closed

#13 @johnjamesjacoby
7 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.